aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-03-15 14:28:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-03-15 22:14:45 +0100
commite14b368dfea9013881a6575a83ca569875542636 (patch)
treec7ae12e1ffaa1ad40b50273cd8d2b8f8712cb1fd /gnu
parentf4e5ed11203bd850e5f2ff29e332b80252e084c9 (diff)
downloadguix-e14b368dfea9013881a6575a83ca569875542636.tar.gz
guix-e14b368dfea9013881a6575a83ca569875542636.zip
gnu: r-parsnip: Update to 0.2.0.
* gnu/packages/cran.scm (r-parsnip): Update to 0.2.0. [propagated-inputs]: Add r-cli, r-ggplot2, and r-withr.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0da12c8607..c76c6d5b33 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -28399,19 +28399,21 @@ analysis using @code{dplyr}, @code{ggplot2}, and other Tidy tools.")
(define-public r-parsnip
(package
(name "r-parsnip")
- (version "0.1.7")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "parsnip" version))
(sha256
(base32
- "12chngdzplwkk1c9k8y7cwaqlyy72yamlknp7ksg7g9p3b58f1fb"))))
+ "0g213c91lzwq9hd22yxkj3igqw04czncnbc4jddnpghp4gpfn1kn"))))
(properties `((upstream-name . "parsnip")))
(build-system r-build-system)
(propagated-inputs
- (list r-dplyr
+ (list r-cli
+ r-dplyr
r-generics
+ r-ggplot2
r-globals
r-glue
r-hardhat
@@ -28422,7 +28424,8 @@ analysis using @code{dplyr}, @code{ggplot2}, and other Tidy tools.")
r-rlang
r-tibble
r-tidyr
- r-vctrs))
+ r-vctrs
+ r-withr))
(native-inputs
(list r-knitr))
(home-page "https://parsnip.tidymodels.org")
ogheader'>2019-05-10system: Export 'operating-system-default-essential-services'.Ludovic Courtès * gnu/system.scm (essential-services): Rename to... (operating-system-default-essential-services): ... this. (<operating-system>)[essential-services]: Adjust accordingly. 2019-04-27system: Add boot file systems to /etc/fstab.Ludovic Courtès * gnu/system.scm (essential-services): Pass FSTAB-SERVICE-TYPE the list of file systems that match 'file-system-needed-for-boot?'. 2019-04-25system: Add guile-readline and guile-colorized to %BASE-PACKAGES.Ludovic Courtès This adds pretty much nothing to the system closure size. * gnu/system.scm (%base-packages): Add GUILE-READLINE and GUILE-COLORIZED. 2019-04-22system: Change default kernel-arguments to '("quiet").Christopher Baines This improves the readability of the boot process, especially when using full disk encryption where you're required to enter the passphrase at a particular point. * gnu/system.scm (<operating-system>)[kernel-arguments]: Change the default to '("quiet"). * doc/guix.texi (operating-system Reference): Document this change. 2019-04-15system: Add 'label' field to <operating-system>.Ludovic Courtès * gnu/system.scm (<operating-system>)[label]: New field. (operating-system-default-label): New procedure. (operating-system-boot-parameters): Use it instead of 'kernel->boot-label'. * doc/guix.texi (operating-system Reference): Document it. 2019-04-14system: Remove "beta" from GRUB menu entries.Ludovic Courtès * gnu/system.scm (kernel->boot-label): Remove "(beta)".