aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-16 19:31:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 19:31:35 +0100
commite0369ba57dd532290a4057113f5ae9a7a8feff86 (patch)
treea995b37f74652d646709fd2d9c4b27483da39ccd /gnu
parenteda31ffaabb080d10a362742e65c45b16cfa96a4 (diff)
downloadguix-e0369ba57dd532290a4057113f5ae9a7a8feff86.tar.gz
guix-e0369ba57dd532290a4057113f5ae9a7a8feff86.zip
gnu: samtools: Update to 1.19.
* gnu/packages/bioinformatics.scm (samtools): Update to 1.19. [source]: Simplify snippet. Change-Id: If0e02bbbc8e0443eb418c078dc47525f432d7ebe
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7ddf6e1afc..b4b848c0c0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8484,20 +8484,20 @@ to the user's query of interest.")
(define-public samtools
(package
(name "samtools")
- (version "1.14")
+ (version "1.19")
(source
(origin
(method url-fetch)
(uri
- (string-append "mirror://sourceforge/samtools/samtools/"
- version "/samtools-" version ".tar.bz2"))
+ (string-append "https://github.com/samtools/samtools"
+ "/releases/download/" version
+ "/samtools-" version ".tar.bz2"))
(sha256
(base32
- "0x3xdda78ac5vx66b3jdsv9sfhyz4npl4znl1zbaf3lbm6xdlhck"))
+ "10wby07w33rfypy4kf73v9wwnbyh0lrazbsmrgrvcl88w8c3nszs"))
(modules '((guix build utils)))
- (snippet '(begin
- ;; Delete bundled htslib.
- (delete-file-recursively "htslib-1.14")))))
+ ;; Delete bundled htslib.
+ (snippet '(delete-file-recursively "htslib-1.19"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--with-ncurses")