aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-05 13:44:49 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-05 17:15:00 +0400
commitdf79cd27f65d4d19613ce938ea0fb6b85fd409ca (patch)
treee21ddb1ad82a8f78e4114e184bb65eb7ec5203d8 /gnu
parent3b4f480b9dca0e97262d2892c88e5f8759b272a3 (diff)
downloadguix-df79cd27f65d4d19613ce938ea0fb6b85fd409ca.tar.gz
guix-df79cd27f65d4d19613ce938ea0fb6b85fd409ca.zip
gnu: Add erlang-ezlib.
* gnu/packages/erlang-xyz.scm (erlang-ezlib): New variable. Change-Id: I342ece260f9bd2d594343ab3afe91cfbced049fd Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/erlang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 488c7a766c..58b503b49c 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -242,6 +242,32 @@ implementation.")
(home-page "https://hex.pm/packages/mqtree")
(license license:asl2.0)))
+(define-public erlang-ezlib
+ (package
+ (name "erlang-ezlib")
+ (version "1.0.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "ezlib" version))
+ (sha256
+ (base32 "1fxz584ry1ib35r74hbmapwq71j5iv5rymm927ys0mgdz2rjmrly"))))
+ (build-system rebar-build-system)
+ (inputs (list erlang-p1-utils))
+ (native-inputs (list erlang-pc))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-environment
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (setenv "CC" "gcc"))))))
+ (synopsis "Native zlib driver for Erlang/Elixir")
+ (description "This package provides native zlib driver for Erlang/Elixir.")
+ (home-page "https://hex.pm/packages/ezlib")
+ (license license:asl2.0)))
+
(define-public erlang-unicode-util-compat
(package
(name "erlang-unicode-util-compat")