aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-23 14:37:06 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:31 +0000
commitdef0034a9b9d09dfdddd6cf5c667ee3e1dc0fc82 (patch)
treee26eec0c4c55a1634c7b188a529fa4a8ab5a90a8 /gnu
parentd08da5605090fd937e8b891dc3491a8bb9850727 (diff)
downloadguix-def0034a9b9d09dfdddd6cf5c667ee3e1dc0fc82.tar.gz
guix-def0034a9b9d09dfdddd6cf5c667ee3e1dc0fc82.zip
gnu: python-pytest-mypy-plugins: Update to 3.1.2.
* gnu/packages/check.scm (python-pytest-mypy-plugins): Update to 3.1.2. Improe package style. [arguments]<tests>: Enable the most of the tests. <phases>: Use custom 'check phase. [propagated-inputs]: Remove python-chevron and python-setuptools; add python-jinja2, python-jsonschema, python-packaging, and python-tomlkit. [native-inputs]: Add python-setuptools. Change-Id: Ice79f75706bf57b97e8e0e8a3b6a54cd6be03946
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm54
1 files changed, 38 insertions, 16 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e22d436c79..8f7cc94b1f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2981,23 +2981,45 @@ a Pytest test execution.")
(define-public python-pytest-mypy-plugins
(package
(name "python-pytest-mypy-plugins")
- (version "1.10.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-mypy-plugins" version))
- (sha256
- (base32
- "05ng29b05gasqj195i9hyyhx5shmwypyvajb7plxwha3g36qq98z"))))
+ (version "3.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mypy-plugins" version))
+ (sha256
+ (base32 "1gpynypn13032by633dr2zhng54v2gl09kwgp3ysc4wpwl09pyhl"))))
(build-system pyproject-build-system)
- (arguments (list #:tests? #false)) ;there are none
- (propagated-inputs (list python-chevron
- python-decorator
- python-mypy
- python-pytest
- python-pyyaml
- python-setuptools
- python-regex))
- (native-inputs (list python-wheel))
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k" (string-join
+ (list "not reveal_type_extension_is_loaded"
+ "test_pyproject_toml"
+ "test_ini_files")
+ " and not "))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Tests failed to run in project's root directory:
+ ;; ModuleNotFoundError: No module named 'pytest_mypy_plugins.tests'
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" "/tmp")
+ (with-directory-excursion "/tmp"
+ (apply invoke "pytest" "-v" test-flags))))))))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-decorator
+ python-jinja2
+ python-jsonschema
+ python-mypy
+ python-packaging
+ python-pytest
+ python-pyyaml
+ python-regex
+ python-tomlkit))
(home-page "https://github.com/TypedDjango/pytest-mypy-plugins")
(synopsis "Pytest plugin for writing tests for mypy plugins")
(description "This package provides a pytest plugin for writing tests for