aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-17 23:06:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-17 23:06:31 +0100
commitdd4f95236692fc40f5773e3e348573030fda3f4d (patch)
treed8acd435c140030619cce1876f00e7903c424826 /gnu
parentb94047cf810c70e6a596cea539e50d487f5c044e (diff)
downloadguix-dd4f95236692fc40f5773e3e348573030fda3f4d.tar.gz
guix-dd4f95236692fc40f5773e3e348573030fda3f4d.zip
gnu: Add r-venn.
* gnu/packages/cran.scm (r-venn): New variable. Change-Id: I6ec3e890cab6e9042686148b7c52988f0dbb878e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 78d78efec7..daf406355d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1910,6 +1910,27 @@ similar rank-based tests for equal probability distributions due to Neuhauser
WebAssembly engine.")
(license license:expat)))
+(define-public r-venn
+ (package
+ (name "r-venn")
+ (version "1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "venn" version))
+ (sha256
+ (base32 "07bjv0m21gljdr3sj1z9rp6xhgxspah9j1m3a8rskvlwv6dvd1pd"))))
+ (properties `((upstream-name . "venn")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-admisc))
+ (home-page "https://github.com/dusadrian/venn")
+ (synopsis "Draw Venn diagrams")
+ (description
+ "This package provides a close to zero dependency package to draw and
+display Venn diagrams up to 7 sets, and any Boolean union of set
+intersections.")
+ (license license:gpl3+)))
+
(define-public r-rvenn
(package
(name "r-rvenn")