aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-03-22 13:57:11 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:48 -0400
commitdd24d0735a908a2479658166ac471a01f333201a (patch)
tree55f71fca6311cd07233791656932c1a93c4dc0a3 /gnu
parent4d2ef2893c75b9362013ed6ae402adcab43490c8 (diff)
downloadguix-dd24d0735a908a2479658166ac471a01f333201a.tar.gz
guix-dd24d0735a908a2479658166ac471a01f333201a.zip
gnu: Add hdf5@1.14.
* gnu/packages/maths.scm (hdf5-1.14): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 61d8e86391..51629a31fd 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1549,6 +1549,26 @@ extremely large and complex data collections.")
(base32 "1zlawdzb0gsvcxif14fwr5ap2gk4b6j02wirr2hcx8hkcbivp20s"))
(patches (search-patches "hdf5-config-date.patch"))))))
+(define-public hdf5-1.14
+ (package
+ (inherit hdf5-1.8)
+ (version "1.14.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
+ "hdf5-" (version-major+minor version)
+ "/hdf5-" version "/src/hdf5-"
+ version ".tar.bz2")
+ (string-append "https://support.hdfgroup.org/ftp/HDF5/"
+ "current"
+ (apply string-append
+ (take (string-split version #\.) 2))
+ "/src/hdf5-" version ".tar.bz2")))
+ (sha256
+ (base32 "181bdh8hp7v9xqwcby3lknr92lxlicc2hqscba3f5nhf8lrr9rz4"))
+ (patches (search-patches "hdf5-config-date.patch"))))))
+
(define-public hdf5
;; Default version of HDF5.
hdf5-1.10)