aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:13:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:30 +0200
commitdd19424bfac7e8edd650d6d0dd7966c2aedc9127 (patch)
tree48d41284c9ca1f2c6d5c0d6a6e4fc311b4370537 /gnu
parent1f43ad80de835ac31ffa768335ef5028301f1d9b (diff)
downloadguix-dd19424bfac7e8edd650d6d0dd7966c2aedc9127.tar.gz
guix-dd19424bfac7e8edd650d6d0dd7966c2aedc9127.zip
gnu: Add texlive-pgf-interference.
* gnu/packages/tex.scm (texlive-pgf-interference): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f2124c569a..825a193d1d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3019,6 +3019,26 @@ PBC, M-nets and B(PN) models; and a third that combines the other two.")
It is configured as a TikZ/PGF library module.")
(license (list license:lppl license:public-domain))))
+(define-public texlive-pgf-interference
+ (package
+ (name "texlive-pgf-interference")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pgf-interference/"
+ "tex/latex/pgf-interference/")
+ (base32
+ "1aa741h358iwn0zd25y3wsr4mr1q2fia1mrfqrbz6p00fvv0rgv5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pgf-interference")
+ (synopsis "Drawing interference patterns with PGF/TikZ")
+ (description
+ "This LaTeX package makes it possible to simulate interference patterns
+occuring on a screen if monochromatic light is diffracted at regular
+structures of slits.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")