aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-09-15 09:20:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-09-15 10:45:37 +0200
commitdc450b938f227d26e324b3a16d85f4dd6559a6b1 (patch)
tree8d5c5cf8e8231489848a46576f7fbc55c8a071ba /gnu
parent76878dfecf1d9c442d75d3795765c67908faa1c7 (diff)
downloadguix-dc450b938f227d26e324b3a16d85f4dd6559a6b1.tar.gz
guix-dc450b938f227d26e324b3a16d85f4dd6559a6b1.zip
gnu: emacs-chatgpt-shell: Update to 1.6.1.
* gnu/packages/emacs-xyz.scm (emacs-chatgpt-shell): Update to 1.6.1. Change-Id: Ie8fef235f0c607482bb0421fda713b58e5f0044f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 16 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9ca043754f..fc053d7a01 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -586,21 +586,32 @@ API key.")
(define-public emacs-chatgpt-shell
(package
(name "emacs-chatgpt-shell")
- (version "1.3.1")
+ (version "1.6.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/xenodium/chatgpt-shell")
- (commit "1de7bfa6a34f20cca813006282d9a8f2ef291f95")))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1rabpp70qlmc47lmp2v7ckvfjhy6wkk881fxpbv2dchzhn77qk5r"))))
+ "1cpfjy47h4xnrk1g7hgxyxc5dwz30xy89ch37ab38nvaqv5ajlqd"))))
(build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; This phase prevents build phase failure.
+ (add-before 'build 'generate-empty-config-file
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (mkdir-p ".emacs.d")
+ (call-with-output-file ".emacs.d/.chatgpt-shell.el"
+ (lambda (port)
+ (display "nil" port))))))))
(home-page "https://github.com/xenodium/chatgpt-shell")
- (synopsis "ChatGPT and DALL-E Emacs shells + Org Babel")
+ (synopsis "ChatGPT and DALL-E Emacs shells and Org Babel libraries")
(description
- "chatgpt-shell is a comint-based ChatGPT shell for Emacs.")
+ "Chatgpt Shell is a Comint-based ChatGPT shell for Emacs.")
(license license:gpl3+)))
(define-public emacs-geiser-guile