aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-03 04:25:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-03 04:32:16 +0200
commitdc198e8e3bc0b2780298e9c8ad64a8d0f8765676 (patch)
tree8903981ef4e5b68d2f7cf0eab462c7b0c2534951 /gnu
parentc60daa8e9dfa5f641ecb5f4f3a9135e27b58d2d7 (diff)
downloadguix-dc198e8e3bc0b2780298e9c8ad64a8d0f8765676.tar.gz
guix-dc198e8e3bc0b2780298e9c8ad64a8d0f8765676.zip
gnu: acpi-call-linux-module: Update to 1.2.2.
* gnu/packages/linux.scm (acpi-call-linux-module): Update to 1.2.2. [arguments]: Stop returning #t from phases. [home-page]: Match source.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5688734b20..1b56a1e315 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1138,7 +1138,7 @@ It has been modified to remove all non-free binary blobs.")
(define-public acpi-call-linux-module
(package
(name "acpi-call-linux-module")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(method git-fetch)
@@ -1147,7 +1147,7 @@ It has been modified to remove all non-free binary blobs.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0mr4rjbv6fj4phf038addrgv32940bphghw2v9n1z4awvw7wzkbg"))))
+ (base32 "1s7h9y3adyfhw7cjldlfmid79lrwz3vqlvziw9nwd6x5qdj4w9vp"))))
(build-system linux-module-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1159,8 +1159,7 @@ It has been modified to remove all non-free binary blobs.")
(lambda _
(substitute* (find-files "examples" ".")
(("^(#! *)/[^ ]*/" _ shebang)
- (string-append shebang "/usr/bin/env ")))
- #t))
+ (string-append shebang "/usr/bin/env ")))))
(add-after 'install 'install-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1169,9 +1168,8 @@ It has been modified to remove all non-free binary blobs.")
(let ((target (string-append doc "/" file)))
(mkdir-p (dirname target))
(copy-recursively file target)))
- (list "README.md" "examples"))
- #t))))))
- (home-page "https://github.com/teleshoes/acpi_call")
+ (list "README.md" "examples"))))))))
+ (home-page "https://github.com/nix-community/acpi_call")
(synopsis "Linux kernel module to perform ACPI method calls")
(description
"This simple Linux kernel module allows calls from user space to any
aux-files/linux-libre/6.1-arm.conf, gnu/packages/aux-files/linux-libre/6.1-arm64.conf, gnu/packages/aux-files/linux-libre/6.1-i686.conf, gnu/packages/aux-files/linux-libre/6.1-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them. 2022-12-29maint: Add a manifest for everything related to linux-libre.Leo Famulari * etc/kernels-manifest.scm: New file. * Makefile.am (EXTRA_DIST): Add it. 2022-12-05Merge branch 'version-1.4.0'Ludovic Courtès 2022-12-03build: Add 'sanity-check-next.py' to the distribution.Ludovic Courtès Reported by Vagrant Cascadian <vagrant@debian.org>. * Makefile.am (AUX_FILES): Add 'sanity-check-next.py'. 2022-11-30maint: Adjust sed script from 'release' target.Ludovic Courtès This is a followup to fdafd404325413da4d5fdd717c84e57a51c60fe2. This effect would to set 'GUIX_DISPLAYED_VERSION' to the empty string. * Makefile.am (release): Remove '/v' from sed script for GUIX_DISPLAYED_VERSION. 2022-11-30build: Build gnu/packages/*.go in two passes.Ludovic Courtès This works around <https://issues.guix.gnu.org/59717>, whereby heap usage would go beyond what's reasonable, preventing compilation of the 'guix' package on armhf-linux. This is a followup to ef82ba9dd94369926eb13325d5e7da4306d23dd7. * Makefile.am (MODULES_PACKAGES1, MODULES_PACKAGES): New variables. (MODULES_PACKAGES): Define in terms of them and use :=. (MODULES_CORE, MODULES_SYSTEM, MODULES_CLI, MODULES_PO): Define with :=. 2022-12-01gnu: raspberry-pi: Add a bootloader-chain for the Raspberry Pi and os examples.Stefan * gnu/packages/raspberry-pi.scm (grub-efi-bootloader-chain-raspi-64): New bootloader variable, capable to boot a Raspberry Pi over network or from a local storage. * gnu/system/examples/raspberry-pi-64.tmpl: New operating-system example. * gnu/system/examples/raspberry-pi-64-nfs-root.tmpl: New operating-system example for booting over network. * Makefile.am (EXAMPLES): Register the new files. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2022-12-01build: kconfig: Add new module to modify defconfig files.Stefan * guix/build/kconfig.scm: New file. * Makefile.am: Register it. * gnu/packages/bootloaders.scm (make-u-boot-package) (make-u-boot-sunxi64-package): Add DEFCONFIGS and CONFIGS arguments. Remove dead code. (u-boot-am335x-boneblack, u-boot-pinebook) (u-boot-novena,u-boot-rockpro64-rk3399): Simplify packages by using the new keyword arguments. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2022-11-15Makefile.am: Sort EXTRA_DIST entries.Maxim Cournoyer * Makefile.am (EXTRA_DIST): Sort. 2022-11-08gnu: Remove linux-libre 5.19.Leo Famulari * gnu/packages/linux.scm (linux-libre-5.19-version, linux-libre-5.19-gnu-revision, deblob-scripts-5.19, linux-libre-5.19-pristine-source, linux-libre-5.19-source, linux-libre-headers-5.19, linux-libre-5.19): Remove variables. * gnu/packages/aux-files/linux-libre/5.19-arm.conf, gnu/packages/aux-files/linux-libre/5.19-arm64.conf, gnu/packages/aux-files/linux-libre/5.19-i686.conf, gnu/packages/aux-files/linux-libre/5.19-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them. 2022-11-02gnu: linux-libre: Add linux-libre 6.0.6.Leo Famulari * gnu/packages/linux.scm (linux-libre-6.0-version, linux-libre-6.0-pristine-source, linux-libre-6.0-source, linux-libre-headers-6.0, linux-libre-6.0): New variables. * gnu/packages/aux-files/linux-libre/6.0-arm.conf, gnu/packages/aux-files/linux-libre/6.0-arm64.conf, gnu/packages/aux-files/linux-libre/6.0-i686.conf, gnu/packages/aux-files/linux-libre/6.0-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them. 2022-10-27build-system: Add pyproject-build-system.Lars-Dominik Braun This is an experimental build system based on python-build-system that implements PEP 517-compliant builds. * doc/guix.texi (Build Systems): Add pyproject-build-system section. * doc/contributing.texi (Python Modules): Mention pyproject.toml and the PYTHON-TOOLCHAIN package, as well as differences to python-build-system. * guix/build-system/pyproject.scm, guix/build/pyproject-build-system.scm, gnu/packages/aux-files/python/sanity-check-next.py, gnu/packages/python-commencement.scm: New files. * Makefile.am (MODULES): Register the new build systems. * gnu/local.mk (GNU_SYSTEM_MODULES): Add python-commencement.scm. * gnu/packages/python.scm (python-sans-pip, python-sans-pip-wrapper): New variables. Co-authored-by: Marius Bakke <marius@gnu.org> 2022-09-08Merge branch 'staging' into core-updatesMarius Bakke 2022-09-06gnu: Remove linux-libre 5.18.Leo Famulari * gnu/packages/linux.scm (linux-libre-5.18-version, linux-libre-5.18-gnu-revision, deblob-scripts-5.18, linux-libre-5.18-pristine-source, linux-libre-5.18-source, linux-libre-headers-5.18, linux-libre-5.18): Remove variables. * gnu/packages/aux-files/linux-libre/5.18-arm.conf, gnu/packages/aux-files/linux-libre/5.18-arm64.conf, gnu/packages/aux-files/linux-libre/5.18-i686.conf, gnu/packages/aux-files/linux-libre/5.18-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them. 2022-09-01Merge branch 'staging' into core-updatesMarius Bakke 2022-08-31gnu: Add linux-libre 5.19.Leo Famulari * gnu/packages/linux.scm (linux-libre-5.19-version, linux-libre-5.19-gnu-revision, deblob-scripts-5.19, linux-libre-5.19-pristine-source, linux-libre-5.19-source, linux-libre-headers-5.19, linux-libre-5.19): New variables. * gnu/packages/aux-files/linux-libre/5.19-arm.conf, gnu/packages/aux-files/linux-libre/5.19-arm64.conf, gnu/packages/aux-files/linux-libre/5.19-i686.conf, gnu/packages/aux-files/linux-libre/5.19-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them. 2022-08-30Merge branch 'staging' into core-updatesMarius Bakke 2022-08-28services: Add lightdm-service-type.Maxim Cournoyer * gnu/services/lightdm.scm: New service. * tests/services/lightdm.scm: Test it. * doc/guix.texi (X Window): Document it. * gnu/local.mk (GNU_SYSTEM_MODULES): Register it. Co-authored-by: L p R n d n <guix@lprndn.info> Co-authored-by: Ricardo Wurmus <rekado@elephly.net> 2022-08-11Merge branch 'staging' into core-updatesMarius Bakke 2022-08-09maint: Use a pretty version string in ISO and VM images.Ludovic Courtès * gnu/system/examples/vm-image.tmpl: Use the 'GUIX_DISPLAYED_VERSION' environment variable in 'label'. * gnu/system/install.scm (%installation-os): Likewise. * Makefile.am (release): Set 'GUIX_DISPLAYED_VERSION'. 2022-08-09system: install: Always use 'current-guix'.Ludovic Courtès Fixes <https://issues.guix.gnu.org/53210>. Reported by Mathieu Othacehe <othacehe@gnu.org>. * gnu/system/install.scm (%installation-services): Set 'guix' to use (current-guix) in 'guix-configuration'. * gnu/system/examples/vm-image.tmpl: Likewise. * gnu/tests/install.scm (operating-system-with-current-guix): Remove. (run-install, installation-os-for-gui-tests): Remove its uses. * Makefile.am (release): Remove intermediate use of 'update-guix-package.scm' and subsequent 'git commit' invocation. 2022-08-09build-system: Add 'channel-build-system'.Ludovic Courtès * gnu/ci.scm (channel-build-system, channel-source->package): Remove. * gnu/packages/package-management.scm (channel-source->package): New procedure, moved from (gnu ci). * guix/build-system/channel.scm: New file, with code moved from (gnu ci). * doc/guix.texi (Build Systems): Document it. 2022-08-08style: Add '--whole-file' option.Ludovic Courtès * guix/scripts/style.scm (format-whole-file): New procedure. (%options, show-help): Add '--whole-file'. (guix-style): Honor it. * tests/guix-style.sh: New file. * Makefile.am (SH_TESTS): Add it. * doc/guix.texi (Invoking guix style): Document it. 2022-08-08style: Move reader and printer to (guix read-print).Ludovic Courtès * guix/scripts/style.scm (<comment>, read-with-comments) (vhashq, %special-forms, %newline-forms, prefix?) (special-form-lead, newline-form?, escaped-string) (string-width, canonicalize-comment, pretty-print-with-comments) (object->string*): Move to... * guix/read-print.scm: ... here. New file. * guix/scripts/import.scm: Adjust accordingly. * tests/style.scm: Move 'test-pretty-print' and tests to... * tests/read-print.scm: ... here. New file. * Makefile.am (MODULES): Add 'guix/read-print.scm'. (SCM_TESTS): Add 'tests/read-print.scm'. 2022-07-22Merge branch 'staging' into core-updatesMarius Bakke 2022-07-08etc: Add 'time-travel-manifest.scm'.Ludovic Courtès This manifest makes it easy to test travels from the current revision back to the revision of a past Guix release. Suggested by zimoun <zimon.toutoune@gmail.com>. * etc/time-travel-manifest.scm: New file. * Makefile.am (EXTRA_DIST): Add it. 2022-07-07Revert "maint: Disable telephony service tests."Maxim Cournoyer This reverts commit c23e0aa65d511a29f31da876f905594c0f8bce00, since the telephony service tests have now been fixed. 2022-07-05maint: Disable telephony service tests.Lars-Dominik Braun Temporarily, so we can bump the guix package. * Makefile.am (SCM_TESTS): Remove tests/services/telephony.scm. 2022-06-29gnu: Remove linux-libre 5.17.Leo Famulari This kernel series is no longer supported upstream. * gnu/packages/linux.scm (linux-libre-5.17-version, linux-libre-5.17-gnu-revision, deblob-scripts-5.17, linux-libre-5.17-pristine-source, linux-libre-5.17-source, linux-libre-headers-5.17, linux-libre-5.17): Remove variables. * gnu/packages/aux-files/linux-libre/5.17-arm.conf, gnu/packages/aux-files/linux-libre/5.17-arm64.conf, gnu/packages/aux-files/linux-libre/5.17-i686.conf, gnu/packages/aux-files/linux-libre/5.17-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them. 2022-06-29gnu: Add linux-libre 5.18.Leo Famulari * gnu/packages/linux.scm (linux-libre-5.18-version, linux-libre-5.18-gnu-revision, deblob-scripts-5.18, linux-libre-5.18-pristine-source, linux-libre-5.18-source, linux-libre-headers-5.18, linux-libre-5.18): New variables. * gnu/packages/aux-files/linux-libre/5.18-arm.conf, gnu/packages/aux-files/linux-libre/5.18-arm64.conf, gnu/packages/aux-files/linux-libre/5.18-i686.conf, gnu/packages/aux-files/linux-libre/5.18-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them.