aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazew@gmail.com>2023-10-07 03:03:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-22 16:38:42 +0300
commitdc114cb898c79caa8144dcb89976cc8a44921057 (patch)
treea1a4b04d865978402f5c53c399aa4ca9ce33eb62 /gnu
parent0d6d68ca51b7d3b0b5260d5576508b99fbf32635 (diff)
downloadguix-dc114cb898c79caa8144dcb89976cc8a44921057.tar.gz
guix-dc114cb898c79caa8144dcb89976cc8a44921057.zip
gnu: Add xremap-sway.
* gnu/packages/rust-apps.scm (xremap-sway): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust-apps.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index cd109c4439..e835426d80 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2574,6 +2574,14 @@ It will then write @code{fixup!} commits for each of those changes.")
(description "This package provides dynamic key remapp for X and Wayland.")
(license license:expat)))
+(define-public xremap-sway
+ (package
+ (inherit rust-xremap)
+ (name "xremap-sway")
+ (arguments
+ (substitute-keyword-arguments (package-arguments rust-xremap)
+ ((#:features _) '(list "sway"))))))
+
(define-public xremap-wlroots
(package
(inherit rust-xremap)
0245d237cdda3a6aeca00e4a'>utils: canonical-newline-port: Fix handling of carriage return at buffer end.Robert Vollmert Prior to this change the added test fails for me locally at byte 1024. It might depend on some default buffer sizes. Fixes <https://bugs.gnu.org/35863>. * tests/utils.scm ("canonical-newline-port-1024"): Add test. * guix/utils.scm (canonical-newline-port): Correct comments on CR/LF. Remove CR even when they're at the end of the buffer. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2019-05-27utils: Support compression and decompression with lzip.Ludovic Courtès * guix/utils.scm (lzip-port): New procedure. (decompressed-port, compressed-port, compressed-output-port): Add 'lzip case. * tests/utils.scm <top level>: Call 'test-compression/decompression' for 'lzip as well. 2019-05-27utils: Test 'compressed-port' and 'decompressed-port' for both gzip and xz.Ludovic Courtès * tests/utils.scm (test-compression/decompression): New procedure. <top level>: Call it for both 'xz and 'gzip.