aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:52:14 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:52:19 +0000
commitdbc9d022ef130717f122f9a6ace9a0b27f9924b6 (patch)
treec3738e7a22257a242654ddaf02dfb0a5e522ddd2 /gnu
parent97cb3321c7203cb24aaa2dba2cbe4b5ca90ebcf5 (diff)
downloadguix-dbc9d022ef130717f122f9a6ace9a0b27f9924b6.tar.gz
guix-dbc9d022ef130717f122f9a6ace9a0b27f9924b6.zip
gnu: python-vine: Fix build.
* gnu/packages/python-xyz.scm (python-vine) [arguments]<test-flags>: Skip 4 tests. [native-inputs]: Remove python-case. Change-Id: I4e8f359556bd97bf6d21a8ac7b7e4823e21043fb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3a7acae776..21845c446d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6521,8 +6521,18 @@ provides Python-specific tags that represent an arbitrary Python object.")
(sha256
(base32 "1q31krwxdvwawdn1kfqmpplix31d4jhs0qng26908hawsf0yjqlb"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; AttributeError: 'test_barrier' object has no attribute 'ps'.
+ #~(list "-k" (string-join
+ (list "not test_evaluate"
+ "test_reverse"
+ "test_cancel"
+ "test_throw")
+ " and not "))))
(native-inputs
- (list python-pytest python-case python-setuptools python-wheel))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/celery/vine")
(synopsis "Promises for Python")
(description