aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 22:53:35 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:54 +0000
commitdb2ccd2479317fc4870e67b8e2c2192361ee08f5 (patch)
treee9644fe5c76d9899468c760104471381fda3b0a6 /gnu
parent3e063c821e205d4166b91bad101a88f0cb8e4021 (diff)
downloadguix-db2ccd2479317fc4870e67b8e2c2192361ee08f5.tar.gz
guix-db2ccd2479317fc4870e67b8e2c2192361ee08f5.zip
gnu: Add go-rsc-io-binaryregexp.
* gnu/packages/golang-xyz.scm (go-rsc-io-binaryregexp): New variable. Change-Id: Idaaac22b1c37b168e5a78e69217a836910a58335
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 75def7f9c5..4269bcdac5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8037,6 +8037,32 @@ also provides V-style logging controlled by the @code{-v} and
defined in @url{https://editorconfig.org/,https://editorconfig.org/}.")
(license license:bsd-3)))
+(define-public go-rsc-io-binaryregexp
+ (package
+ (name "go-rsc-io-binaryregexp")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rsc/binaryregexp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kar0myy85waw418zslviwx8846zj0m9cmqkxjx0fvgjdi70nc4b"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "rsc.io/binaryregexp"))
+ (home-page "https://pkg.go.dev/rsc.io/binaryregexp")
+ (synopsis "Golang regexp for binary/latin-1 data")
+ (description
+ "Package regexp implements regular expression search. The syntax of the
+regular expressions accepted is the same general syntax used by Perl, Python,
+and other languages. More precisely, it is the syntax accepted by RE2 and
+described at https://golang.org/s/re2syntax, except for @code{\\C.}")
+ (license license:bsd-3)))
+
(define-public go-zgo-at-jfmt
(package
(name "go-zgo-at-jfmt")