aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:14:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:31 +0200
commitda5e05d8ecfd6ebb1fe2e507030218037f307877 (patch)
tree73a993c83caa81582f6c165b7ae2f46e5674c6f6 /gnu
parent48d7613bdca8a1b552f5aec4eb6f0a277bd33267 (diff)
downloadguix-da5e05d8ecfd6ebb1fe2e507030218037f307877.tar.gz
guix-da5e05d8ecfd6ebb1fe2e507030218037f307877.zip
gnu: Add texlive-pgf-spectra.
* gnu/packages/tex.scm (texlive-pgf-spectra): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 72717bdb95..66e6d99b9f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3100,6 +3100,28 @@ using PGF/TikZ.")
soroban (Japanese abacus) using PGF/TikZ.")
(license license:lppl)))
+(define-public texlive-pgf-spectra
+ (package
+ (name "texlive-pgf-spectra")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pgf-spectra/"
+ "tex/latex/pgf-spectra/")
+ (base32
+ "03jci0jc5ryzkp6930hn1l4awjrw9y1xwc3f327igccj78w24pnb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pgf-spectra")
+ (synopsis "Draw continuous or discrete spectra using PGF/TikZ")
+ (description
+ "The purpose of this package is to draw the spectra of elements in
+a simple way. It relies on PGF/TikZ for drawing the desired spectrum,
+continuous or discrete. There are data available for the spectra of 98
+elements and their ions (from the NASA database and from NIST). It also
+allows the user to draw spectra using their own data.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")