aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-03 14:42:33 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-03 14:59:05 +0100
commitd897f1b440fde666415be4027fa71ea91f6084fb (patch)
tree1a5229da57edaf51f24d5f9092d0539b4e3294bc /gnu
parent38bbed33a28524c26ca794117f6dfed1529e2807 (diff)
downloadguix-d897f1b440fde666415be4027fa71ea91f6084fb.tar.gz
guix-d897f1b440fde666415be4027fa71ea91f6084fb.zip
gnu: netdde: Add default case.
This fixes evaluation of ‘master’, which was failing with a ‘match’ error. * gnu/packages/hurd.scm (netdde)[arguments]: Add default case. Change-Id: I093b21f629a930f6e6b43430f5a204d06e1f3aad
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/hurd.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 61833219c4..e0369a7af3 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
-;;; Copyright © 2018, 2020-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018, 2020-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020, 2022, 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
@@ -636,7 +636,11 @@ implementing them.")
((? target-x86-32?)
"x86")
((? target-x86-64?)
- "amd64"))))
+ "amd64")
+ (_
+ ;; XXX: Cross-compiling this package to an
+ ;; unsupported system.
+ "UNSUPPORTED_SYSTEM"))))
(string-append "ARCH=" arch)))
#:configure-flags
,#~(list (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))