aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 21:01:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:53 +0000
commitd83434fc5b57a4d08d5a9e4b2de9a3055f5e0d92 (patch)
tree2d29e45fbd3002f4f0a3282ed945c9443bdc5698 /gnu
parent7ff9ab32be9164540bb97634b1c4fc31ba1dff51 (diff)
downloadguix-d83434fc5b57a4d08d5a9e4b2de9a3055f5e0d92.tar.gz
guix-d83434fc5b57a4d08d5a9e4b2de9a3055f5e0d92.zip
gnu: go-github-com-sevlyar-go-daemon: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-sevlyar-go-daemon): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/vpn.scm: Add to used golang-xyz module. Change-Id: I0c1084983440bb45b6621cd0b2d7ba8d30ee8ff7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/golang.scm24
-rw-r--r--gnu/packages/vpn.scm1
3 files changed, 28 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 044b044d78..87bd331430 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Guix Together <jgart@dismail.de>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 Ramana Radhakrishnan <ramana.radhakrishnan@arm.com>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 raingloom <raingloom@riseup.net>
@@ -43,8 +44,8 @@
;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Luis Higino <luishenriquegh2701@gmail.com>
-;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -6524,6 +6525,31 @@ synchronizing plain text:
@end itemize")
(license license:expat)))
+(define-public go-github-com-sevlyar-go-daemon
+ (package
+ (name "go-github-com-sevlyar-go-daemon")
+ (version "0.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sevlyar/go-daemon")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x2sn871g10jihga6jvng7ys1988dgj24wlkxzdzca6mvzysj80b"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/sevlyar/go-daemon"))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://github.com/sevlyar/go-daemon")
+ (synopsis "Library for writing system daemons")
+ (description
+ "Go-Daemon is a library for writing system daemons in Go.")
+ (license license:expat)))
+
(define-public go-github-com-shirou-gopsutil
(package
(name "go-github-com-shirou-gopsutil")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a5e7da3652..116ab3a94c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2249,30 +2249,6 @@ incorporates ideas and concepts from Philipp Winter's ScrambleSuit protocol.")
web browsing activities based on HTTP Upgrade (HTTPT).")
(license license:bsd-2))))
-(define-public go-github-com-sevlyar-go-daemon
- (package
- (name "go-github-com-sevlyar-go-daemon")
- (version "0.1.6")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/sevlyar/go-daemon")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1x2sn871g10jihga6jvng7ys1988dgj24wlkxzdzca6mvzysj80b"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/sevlyar/go-daemon"))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (home-page "https://github.com/sevlyar/go-daemon")
- (synopsis "Library for writing system daemons")
- (description "Go-Daemon is a library for writing system daemons in Go.")
- (license license:expat)))
-
(define-public go-github-com-keybase-go-ps
(let ((commit "91aafc93ba19d1988cff338c1929d35b6c6f5b50")
(revision "0"))
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 9f36595bfd..9ee1f95af7 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -74,6 +74,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages guile)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)