aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-21 17:15:23 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:45 +0000
commitd5bc9a94a1725c8d5b79cc2553415a2b06bcfd89 (patch)
tree0323f1cacdbf1d7c68a9a1ecfbe388e38f2ef0e3 /gnu
parentb34852a4c3628c3daf4faa4370a3cddfbfdd17bb (diff)
downloadguix-d5bc9a94a1725c8d5b79cc2553415a2b06bcfd89.tar.gz
guix-d5bc9a94a1725c8d5b79cc2553415a2b06bcfd89.zip
gnu: python-sncosmo: Update to 2.11.2.
* gnu/packages/astronomy.scm (python-sncosmo): Update to 2.11.2. Change-Id: I00ec74de18a88782895e185edb063e9508b90d46
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm66
1 files changed, 34 insertions, 32 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 946f327566..618837656a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2742,49 +2742,51 @@ and the options
(define-public python-sncosmo
(package
(name "python-sncosmo")
- (version "2.11.1")
+ (version "2.11.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sncosmo" version))
(sha256
- (base32 "0nmhrvaw22zxpmykl70a91mc88pxmw0x5fdxjiz3hdzkdbqrg0x9"))))
+ (base32 "1n7kh2qinp04ilf8d26hgjs6c3bdy5vbmppc6ps9jy1q0ll8gi69"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
;; Disable tests requireing remote access to download test data.
#~(list
- "-k" (string-append "not test_megacampsf_bandpass"
- " and not test_builtins_remote_aa"
- " and not test_builtins_remote_nm"
- " and not test_builtins_remote_um"
- " and not test_builtins_remote_wfc3"
- " and not test_builtins_megacampsf"
- " and not test_builtins_timeseries_ascii"
- " and not test_builtins_timeseries_fits"
- " and not test_builtins_salt2model"
- " and not test_builtins_salt3model"
- " and not test_builtins_2011fe"
- " and not test_builtins_mlcs2k2"
- " and not test_builtins_snemo"
- " and not test_builtins_sugar"
- " and not test_builtins_magsys_fits"
- " and not test_builtins_magsys_csp"
- " and not test_builtins_magsys_ab_b12"
- " and not test_builtins_magsys_jla"
- " and not test_csp_magsystem"
- " and not test_compositemagsystem_band_error"
- " and not test_G10"
- " and not test_C11"
- " and not test_salt2source_timeseries_vs_snfit"
- " and not test_salt2source_rcov_vs_snfit"
- " and not test_bandflux"
- " and not test_bandflux_multi"
- " and not test_bandflux_zpsys"
- " and not test_bandfluxcov"
- " and not test_bandmag"
- " and not test_sugarsource"))
+ "-k" (string-join
+ (list "not test_megacampsf_bandpass"
+ "test_builtins_remote_aa"
+ "test_builtins_remote_nm"
+ "test_builtins_remote_um"
+ "test_builtins_remote_wfc3"
+ "test_builtins_megacampsf"
+ "test_builtins_timeseries_ascii"
+ "test_builtins_timeseries_fits"
+ "test_builtins_salt2model"
+ "test_builtins_salt3model"
+ "test_builtins_2011fe"
+ "test_builtins_mlcs2k2"
+ "test_builtins_snemo"
+ "test_builtins_sugar"
+ "test_builtins_magsys_fits"
+ "test_builtins_magsys_csp"
+ "test_builtins_magsys_ab_b12"
+ "test_builtins_magsys_jla"
+ "test_csp_magsystem"
+ "test_compositemagsystem_band_error"
+ "test_G10"
+ "test_C11"
+ "test_salt2source_timeseries_vs_snfit"
+ "test_salt2source_rcov_vs_snfit"
+ "test_bandflux"
+ "test_bandflux_multi"
+ "test_bandflux_zpsys"
+ "test_bandfluxcov"
+ "test_bandmag"
+ "test_sugarsource")
+ " and not "))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements