aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 21:52:50 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:44 +0200
commitd56532c568d66c4b38552c0c96777d4b770374a2 (patch)
tree0da8fd412d12e9968632fcdb50f89c0aedb8578c /gnu
parent6746ea2ea329efd496a57dc585aab75cf2f650bf (diff)
downloadguix-d56532c568d66c4b38552c0c96777d4b770374a2.tar.gz
guix-d56532c568d66c4b38552c0c96777d4b770374a2.zip
gnu: patchelf: Fix test suite.
* gnu/packages/elf.scm (patchelf)[arguments]: Adjust 'fix-tests phase for changes in the test suite. Change-Id: Iffeb4ef94e0d78edd47d9d8b6e316f3b29627ed0
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/elf.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 688aeed076..dc2db83632 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2017-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -307,8 +307,10 @@ static analysis of the ELF binaries at hand.")
(substitute* "tests/set-empty-rpath.sh"
;; Binaries with empty RPATHs cannot run on Guix, because
;; we still need to find libgcc_s (see above).
- (("^\\$\\{SCRATCH\\}\\/simple.$") ""))
- #t)))))
+ (("^\"\\$\\{SCRATCH\\}\"\\/simple.$") ""))
+ ;; Skip this test for now.
+ (substitute* "tests/Makefile.in"
+ ((".*shared-rpath\\.sh \\.*") "")))))))
(native-inputs
`(("gcc:lib" ,gcc "lib")))
(home-page "https://nixos.org/patchelf.html")