aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2024-11-03 13:04:05 +0100
committerJelle Licht <jlicht@fsfe.org>2024-12-18 22:02:20 +0100
commitd4caaf2a92d7b52a0961c15b7e01ffd807460a90 (patch)
tree35760ba9b4098ec6a1fe9c3fd4a789d139c221b5 /gnu
parent3602ccfcd39dd87dc2dc4b90610d8447e86ec8db (diff)
downloadguix-d4caaf2a92d7b52a0961c15b7e01ffd807460a90.tar.gz
guix-d4caaf2a92d7b52a0961c15b7e01ffd807460a90.zip
gnu: vlang: Use node-lts instead of node.
* gnu/packages/vlang.scm (vlang)[native-inputs]: Replace node by node-lts. Change-Id: Iaf577f0b9bbd7095392c88c2d2737c0703d3bf96
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/vlang.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/vlang.scm b/gnu/packages/vlang.scm
index 4741483f12..db3b6a66aa 100644
--- a/gnu/packages/vlang.scm
+++ b/gnu/packages/vlang.scm
@@ -133,7 +133,7 @@
("git" ,git-minimal)
;; For the tests.
("libx11" ,libx11)
- ("node" ,node)
+ ("node" ,node-lts)
("openssl" ,openssl)
("sqlite" ,sqlite)))
(home-page "https://vlang.io/")
ld be thrown: ice-9/boot-9.scm:1685:16: In procedure raise-exception: ERROR: 1. &ambiguous-target-service-error: service: #<<service> type: #<service-type rpcbind 7f7529853780> value: #<<rpcbind-configuration> rpcbind: #<package rpcbind@1.2.6 gnu/packages/onc-rpc.scm:87 7f75389e78f0> warm-start?: #t>> target-type: #<service-type shepherd-root 7f7529396080> 2. &message: "more than one target service of type 'shepherd-root'" The problem was that the rpcbind shepherd-service object was dynamically instantiated every time the rpcbind-service-type would be called, causing multiple objects in some situations, resulting in the above condition. * gnu/services/nfs.scm (rpcbind-service-type): Refactor and adjust in a way to extract... (rpcbind-shepherd-service): ... this new procedure. 2021-12-23services: nfs: Fix statd and mountd ports.Mathieu Othacehe * gnu/services/nfs.scm (nfs-shepherd-services): Fix rpcstatd-port and rpcmountd-port arguments.