aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-04 15:04:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:18 +0000
commitcfd383f263f528e29eb5c2fa9f5001d2fc87f489 (patch)
tree63b1300beca1a38e5b2b3e7fdf1678a95e0e9973 /gnu
parent332fad5cb1a510fbe43e1ae0c22b10b15b37ad83 (diff)
downloadguix-cfd383f263f528e29eb5c2fa9f5001d2fc87f489.tar.gz
guix-cfd383f263f528e29eb5c2fa9f5001d2fc87f489.zip
gnu: Add python-pymcubes.
* gnu/packages/python-science.scm (python-pymcubes): New variable. Change-Id: I47273d933824fb96d3c2c1950f0a2f89ce635c41
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7c8d41cdc2..9169c28248 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1382,6 +1382,48 @@ package was a port of the R package by the same name and it is inspired by the
ease-of-use and expressiveness of the @code{dplyr} package.")
(license license:expat)))
+(define-public python-pymcubes
+ (package
+ (name "python-pymcubes")
+ (version "0.1.6")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI
+ (uri (git-reference
+ (url "https://github.com/pmneila/PyMCubes")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1v2qhc4pwanx6a8k843mbh45yk77n3w63sy5lzk5c3q4pkvfj1b9"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'prepare-test-environment
+ (lambda _
+ ;; FileNotFoundError: [Errno 2] No such file or directory:
+ ;; 'output/test.obj'
+ (mkdir "output")
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs
+ (list python-cython
+ python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-pycollada
+ python-numpy
+ python-scipy))
+ (home-page "https://github.com/pmneila/PyMCubes")
+ (synopsis "Marching cubes for Python")
+ (description
+ "@code{PyMCubes} is an implementation of the marching cubes algorithm to
+extract iso-surfaces from volumetric data. The volumetric data can be given
+as a three-dimensional @code{NumPy} array or as a Python function @code{f(x,
+y, z)}.")
+ (license license:bsd-3)))
+
(define-public python-pythran
(package
(name "python-pythran")
nd perl. Jan (janneke) Nieuwenhuizen 2020-04-23gnu: autoconf: Support cross-build....Autoconf does not cross-built properly: it lacks the concept of <tool>-for-build. It runs the host `autom4te' (a perl script) during build. * gnu/packages/autotools.scm (autoconf)[inputs]: Add bash-minimal, perl, and m4. To avoid triggering a rebuild, do this while cross-compiling only. [arguments]: When cross-building, add `patch-non-shebang-references' phase to substitute the host bash, m4 and perl. Jan (janneke) Nieuwenhuizen 2020-03-27gnu: Automake: Remove version 1.16.1....* gnu/packages/autotools.scm (automake): Update to 1.16.2. [arguments]: Add phase "skip-test". (automake-1.16.2): Remove variable. Marius Bakke 2020-03-27Merge branch 'master' into core-updates... Conflicts: gnu/packages/icu4c.scm gnu/packages/man.scm gnu/packages/python-xyz.scm guix/scripts/environment.scm guix/scripts/pack.scm guix/scripts/package.scm guix/scripts/pull.scm guix/store.scm Marius Bakke 2020-03-24gnu: automake: Add version 1.16.2....* gnu/packages/autotools.scm (automake-1.16.2): New variable. Ludovic Courtès 2020-03-14Merge branch 'master' into core-updatesMarius Bakke 2020-03-13gnu: autobuild: Use HTTPS home page....* gnu/packages/autotools.scm (autobuild)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-02-16gnu: autoconf: Use HTTPS home page....* gnu/packages/autotools.scm (autoconf)[home-page]: Use HTTPS. Tobias Geerinckx-Rice