aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2024-12-02 13:53:53 +0100
committerJelle Licht <jlicht@fsfe.org>2024-12-18 22:02:20 +0100
commitcf6a25ae73cd9b9675f2f5fe7f569826da02bd3a (patch)
tree75e4b20966bbab11e9d27cdea7900a0c2aebdd83 /gnu
parentd925b8c3db380676421ad139dd3d7a44dee55dfb (diff)
downloadguix-cf6a25ae73cd9b9675f2f5fe7f569826da02bd3a.tar.gz
guix-cf6a25ae73cd9b9675f2f5fe7f569826da02bd3a.zip
gnu: node-addon-api: Update to 8.3.0.
* gnu/packages/node-xyz.scm (node-addon-api): Update to 8.3.0. [arguments]<#:phases>: Delete additional optional dependencies in 'delete-dependencies' phase. Change-Id: I86c6b026980aea02a20f889bc7f92ea3a304e674
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index a8f6a273fa..e98eda2a01 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -114,7 +114,7 @@ architecture supporting plugins.")
(define-public node-addon-api
(package
(name "node-addon-api")
- (version "4.2.0")
+ (version "8.3.0")
(source
(origin
(method git-fetch)
@@ -123,7 +123,7 @@ architecture supporting plugins.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1bhvfi2m9nxfz418s619914vmidcnrzbjv6l9nid476c3zlpazch"))))
+ (base32 "1swvhdss2w636l24bnssnwb1rqh7i6lhpkk4knbrvpspqf80kagc"))))
(inputs
(list python node-safe-buffer))
(build-system node-build-system)
@@ -148,8 +148,10 @@ architecture supporting plugins.")
"eslint-plugin-node"
"eslint-plugin-promise"
"fs-extra"
+ "neostandard"
"path"
- "pre-commit"))))
+ "pre-commit"
+ "semver"))))
(add-after 'unpack 'skip-js-tests
;; We can't run the js-based tests,
;; but we can still do the C++ parts