aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-17 00:29:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:21 +0200
commitcf5411ecb0bd26f9814a481ffbdf1203d2a597e2 (patch)
treed73d669141015025f9027738fc380b9b932f0267 /gnu
parent6dc6577330e99c29f41d22d3c48e66da383b04b7 (diff)
downloadguix-cf5411ecb0bd26f9814a481ffbdf1203d2a597e2.tar.gz
guix-cf5411ecb0bd26f9814a481ffbdf1203d2a597e2.zip
gnu: texlive-cbfonts-fd: Refresh package definition.
* gnu/packages/tex.scbfonts-fd (texlive-cbfonts-fd): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm50
1 files changed, 28 insertions, 22 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 79621a6f8e..57c3e01830 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1138,42 +1138,48 @@ sizes as are such font sets as the EC fonts.")
(define-public texlive-cbfonts-fd
(package
- (inherit (simple-texlive-package
- "texlive-cbfonts-fd"
- (list "/doc/fonts/cbfonts/"
- "/tex/latex/cbfonts-fd/")
- (base32
- "0g91p2qcgqn916vgf777h45dabv2r6l6f9xkcq0b3gpir3qsj3d4")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/cbfonts-fd")
+ (name "texlive-cbfonts-fd")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/cbfonts-fd/"
+ "source/fonts/cbfonts-fd/"
+ "tex/latex/cbfonts-fd/")
+ (base32
+ "1r2kmnccvrq181ac7gyff9y3wn7dydx50jy8f9n6qhnb824pdn78")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/cbfonts-fd")
(synopsis "LaTeX font description files for the CB Greek fonts")
- (description "The package provides font description files for all the many
-shapes available from the cbfonts collection. The files provide the means
-whereby the @acronym{NFSS, New Font Selection Scheme} knows which fonts a
-LaTeX user is requesting.
+ (description
+ "The package provides font description files for all the many shapes
+available from the @code{cbfonts} collection. The files provide the means
+whereby the @acronym{NFSS, New Font Selection Scheme} knows which fonts
+a LaTeX user is requesting.
Tip: installing @code{texlive-cbfonts} will automatically propagate this one.")
(license license:lppl1.3c+)))
(define-public texlive-cite
(package
- (inherit (simple-texlive-package
- "texlive-cite"
- (list "doc/latex/cite/" "tex/latex/cite/")
- (base32
- "0b1amznayxj80dmqbzcysmj7q8aksbyz98k6djsqi0mhwp1cd0fd")
- #:trivial? #t))
+ (name "texlive-cite")
(version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/cite/" "tex/latex/cite/")
+ (base32
+ "0b1amznayxj80dmqbzcysmj7q8aksbyz98k6djsqi0mhwp1cd0fd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
(home-page "https://ctan.org/pkg/cite")
(synopsis "Improved citation handling in LaTeX")
(description
"The package supports compressed, sorted lists of numerical citations,
and also deals with various punctuation and other issues of representation,
including comprehensive management of break points. The package is compatible
-with both hyperref and backref. The package is (unsurprisingly) part of the
-cite bundle of the author's citation-related packages.")
- (license (license:fsf-free
- "/share/texmf-dist/doc/latex/cite/README"))))
+with both @code{hyperref} and @code{backref}. The package is (unsurprisingly)
+part of the cite bundle of the author's citation-related packages.")
+ (license (license:fsf-free "/share/texmf-dist/doc/latex/cite/README"))))
(define-public texlive-cm
(package