aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-20 19:02:57 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:16 +0200
commitccb4a92c342b0bc721ed7baceac22b3e14f651a8 (patch)
tree6a67a6a2ee1de5e51a321acbcbf1cb451bd96ed8 /gnu
parent052d12f040c9f253032ee4af0145aa5a7b90872c (diff)
downloadguix-ccb4a92c342b0bc721ed7baceac22b3e14f651a8.tar.gz
guix-ccb4a92c342b0bc721ed7baceac22b3e14f651a8.zip
gnu: openssl@1.1: Ungraft.
* gnu/packages/tls.scm (openssl-1.1): Update to 1.1.1u. [replacement]: Remove. (openssl/fixed): Remove. Change-Id: Idd77b57276ea132eee8c2c3fe801150c7789ac59
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 3fbcfeda0f..2f2a41f650 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -437,8 +437,7 @@ OpenSSL for TARGET."
(define-public openssl-1.1
(package
(name "openssl")
- (version "1.1.1q")
- (replacement openssl/fixed)
+ (version "1.1.1u")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -451,7 +450,7 @@ OpenSSL for TARGET."
(patches (search-patches "openssl-1.1-c-rehash-in.patch"))
(sha256
(base32
- "1jhhzp4gh6ymidxm1ckjk948l583awp0w3y2nvqdz7022kk9r4yp"))))
+ "1ipbcdlqyxbj5lagasrq2p6gn0036wq6hqp7gdnd1v1ya95xiy72"))))
(build-system gnu-build-system)
(outputs '("out"
"doc" ;6.8 MiB of man3 pages and full HTML documentation
@@ -562,25 +561,6 @@ OpenSSL for TARGET."
(license license:openssl)
(home-page "https://www.openssl.org/")))
-(define openssl/fixed
- (package
- (inherit openssl-1.1)
- (name "openssl")
- (version "1.1.1u")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "https://www.openssl.org/source/openssl-"
- version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/"
- "openssl-" version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/old/"
- (string-trim-right version char-set:letter)
- "/openssl-" version ".tar.gz")))
- (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
- (sha256
- (base32
- "1ipbcdlqyxbj5lagasrq2p6gn0036wq6hqp7gdnd1v1ya95xiy72"))))))
-
(define-public openssl-3.0
(package
(inherit openssl-1.1)