aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 17:01:58 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:29 -0600
commitc8d68ff9c3763abd24473dd2d414e581ef5ca059 (patch)
tree9f00dc26815a26177cd563a430b8e0dd051177e6 /gnu
parent21a99dda72ad165c8823c6580cfb6f687d72a7ac (diff)
downloadguix-c8d68ff9c3763abd24473dd2d414e581ef5ca059.tar.gz
guix-c8d68ff9c3763abd24473dd2d414e581ef5ca059.zip
gnu: Add Scalar-List-Utils.
* gnu/packages/perl.scm (perl-scalar-list-utils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 49fbe5c303..8a99ab7713 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2104,4 +2104,25 @@ the \"Module::Build\" code is pure-perl and written in a cross-platform way.")
files, using JSON::PP and/or CPAN::Meta::YAML.")
(license (package-license perl))))
+(define-public perl-scalar-list-utils
+ (package
+ (name "perl-scalar-list-utils")
+ (version "1.41")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PE/PEVANS/"
+ "Scalar-List-Utils-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04l1q4hps9n8b1hk9kpgpc1cryim7pl9sfdyb7fz5nq4gmz307j7"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Scalar-List-Utils")
+ (synopsis "Common Scalar and List utility subroutines")
+ (description "This package contains a selection of subroutines that people
+have expressed would be nice to have in the perl core, but the usage would not
+really be high enough to warrant the use of a keyword, and the size so small
+such that being individual extensions would be wasteful.")
+ (license (package-license perl))))
+
;;; END: Core module overrides