aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-09 13:58:42 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:29 -0400
commitc784aefb4669af77309f6b42ec950c7354bdc7b8 (patch)
treee533ae6a0369495fcc49713c9cecbfcc5d4910fc /gnu
parentc665ec7a23eed9a07deefb24e5f3aca0e8fe789a (diff)
downloadguix-c784aefb4669af77309f6b42ec950c7354bdc7b8.tar.gz
guix-c784aefb4669af77309f6b42ec950c7354bdc7b8.zip
gnu: Add ruby-io-console.
* gnu/packages/ruby.scm (ruby-io-console): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index eb71b344f8..46bdaa38d1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -513,6 +513,33 @@ an extensible architecture with a swappable backend.")
(home-page "https://github.com/ruby-i18n/i18n")
(license license:expat)))
+(define-public ruby-io-console
+ (package
+ (name "ruby-io-console")
+ (version "0.6.0")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/ruby/io-console/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gwxrp29b6awkid1sf85sbh529mnq6hb86m8c2443cm6nc4vr8qb"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'delete-rakelib-files
+ (lambda _
+ ;; These depend on git and other extraneous
+ ;; dependencies, and are loaded by rake.
+ (delete-file-recursively "rakelib"))))))
+ (native-inputs (list ruby-rake-compiler))
+ (synopsis "Console capabilities library for IO instances")
+ (description "IO.console adds console capabilities to Ruby IO instances.")
+ (home-page "https://github.com/ruby/io-console")
+ (license license:bsd-2)))
+
(define-public ruby-iruby
(package
(name "ruby-iruby")