aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-09 14:01:36 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:34 +0800
commitc732b0e018f68cb22b9b0ae5580d52ca9ae5db46 (patch)
treefa687ab7d2cff8494deaed0885caa9a24edffcb8 /gnu
parent4ff3384d9e49a37f81d85aebf9bf8704e332237c (diff)
downloadguix-c732b0e018f68cb22b9b0ae5580d52ca9ae5db46.tar.gz
guix-c732b0e018f68cb22b9b0ae5580d52ca9ae5db46.zip
gnu: hotspot: Update to 1.5.1.
* gnu/packages/linux.scm (hotspot): Update to 1.5.1. [arguments]: Set #:qtbase to qtbase. <#:configure-flags>: Pass -DQT6_BUILD=ON. [inputs]: Add ki18n, qtdeclarative and qtsvg. Remove qcustomplot, qtbase-5, qtdeclarative-5, qtquickcontrols2-5, qtsvg-5, qtx11extras. Change-Id: I8daf6b74b662f54b3555035ec7c9395472e8d9a6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4979a8d3cb..9ace92acbd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7171,7 +7171,7 @@ not as a replacement for it.")
(define-public hotspot
(package
(name "hotspot")
- (version "1.5.0")
+ (version "1.5.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7183,7 +7183,7 @@ not as a replacement for it.")
(file-name (git-file-name name version))
(sha256
(base32
- "17m96h0iahfjhbsa9flmsmbczvliy34vqvayzyh8bhldd8yh768l"))))
+ "04k2rvf2lgi8hp7dzqzn65fcd2lsiylwr04d44q75j0wvgbjjv1v"))))
(build-system qt-build-system)
(arguments
(list
@@ -7191,7 +7191,9 @@ not as a replacement for it.")
;; installed to a custom prefix and the build fails with "file cannot
;; create directory: /polkit-1/actions. Maybe need administrative"
;; (see: https://bugs.kde.org/show_bug.cgi?id=363678).
- #:configure-flags #~(list "-DINSTALL_KAUTH_HELPER=OFF")
+ #:configure-flags #~(list "-DINSTALL_KAUTH_HELPER=OFF"
+ "-DQT6_BUILD=ON")
+ #:qtbase qtbase
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-perfparser
@@ -7262,6 +7264,7 @@ not as a replacement for it.")
kcoreaddons
kddockwidgets
kgraphviewer
+ ki18n
kio
kiconthemes
kitemmodels
@@ -7272,12 +7275,8 @@ not as a replacement for it.")
kwindowsystem
libxkbcommon
perf
- qcustomplot
- qtbase-5
- qtdeclarative-5
- qtquickcontrols2-5
- qtsvg-5
- qtx11extras
+ qtdeclarative
+ qtsvg
solid
threadweaver
`(,zstd "lib"))