aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 22:14:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:05 +0200
commitc6b1480151a675e265f669d686cd3a8eb3280d1e (patch)
tree61f7b3f2197fe86333068a56b6638a8cf2a120e9 /gnu
parentdfee2a969ef21b676aaf2561060b7ed193fa407f (diff)
downloadguix-c6b1480151a675e265f669d686cd3a8eb3280d1e.tar.gz
guix-c6b1480151a675e265f669d686cd3a8eb3280d1e.zip
gnu: Add texlive-curve.
* gnu/packages/tex.scm (texlive-curve): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index edf3311833..1e22fe34e6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16642,6 +16642,33 @@ graphics part, as far as LaTeX part does not do it; and rescaling and rotating
of complete graphics.")
(license license:gpl3+)))
+(define-public texlive-curve
+ (package
+ (name "texlive-curve")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/curve/" "source/latex/curve/"
+ "tex/latex/curve/")
+ (base32
+ "0780i6zr24v30ixn6zcalqr2pdp5jkxk8ksfw090aaq03wpxmggg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:tex-format "latex"))
+ (home-page "https://ctan.org/pkg/curve")
+ (synopsis "Class for making curriculum vitae")
+ (description
+ "CurVe is a class for writing a CV, with configuration for the language
+in which you write. The class provides a set of commands to create rubrics,
+entries in these rubrics etc. CurVe then format the CV (possibly splitting it
+onto multiple pages, repeating the titles etc), which is usually the most
+painful part of CV writing. Another nice feature of CurVe is its ability to
+manage different CV flavours simultaneously. It is often the case that you
+want to maintain slightly divergent versions of your CV at the same time, in
+order to emphasize on different aspects of your background. CurVe also comes
+with support for use with AUC-TeX.")
+ (license license:lppl)))
+
(define-public texlive-gates
(package
(name "texlive-gates")