aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 22:11:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:12 +0200
commitc5ec7db831b88ec9047ea89d2d20571e9cd72cc7 (patch)
treeacf98534b28a14dd619b55a42fb3ae13472cb90b /gnu
parent1d0ded385ecadc8be4d8c222cd614a4ca4ea5b2d (diff)
downloadguix-c5ec7db831b88ec9047ea89d2d20571e9cd72cc7.tar.gz
guix-c5ec7db831b88ec9047ea89d2d20571e9cd72cc7.zip
gnu: texlive-greek-fontenc: Refresh package definition.
* gnu/packages/tex.scm (texlive-greek-fontenc): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 40615d3d87..8dbffa831d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3755,19 +3755,22 @@ documents. It comprises the packages @code{color}, @code{graphics},
(define-public texlive-greek-fontenc
(package
- (inherit (simple-texlive-package
- "texlive-greek-fontenc"
- (list "doc/latex/greek-fontenc/"
- "tex/latex/greek-fontenc/"
- "source/latex/greek-fontenc/")
- (base32
- "1ncsvj5mlnkgllrvqdnbkv0qwpv2y7jkq3x2wdmm7d3daqq0ka5h")
- #:trivial? #t))
- (home-page "https://ctan.org/language/greek/greek-fontenc")
+ (name "texlive-greek-fontenc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/greek-fontenc/"
+ "source/latex/greek-fontenc/"
+ "tex/latex/greek-fontenc/")
+ (base32
+ "1ncsvj5mlnkgllrvqdnbkv0qwpv2y7jkq3x2wdmm7d3daqq0ka5h")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/greek-fontenc")
(synopsis "LICR macros and encoding definition files for Greek")
(description
- "The package provides Greek LICR macro definitions and encoding definition files
-for Greek text font encodings for use with fontenc.")
+ "The package provides Greek LICR macro definitions and encoding
+definition files for Greek text font encodings for use with @code{fontenc}.")
(license license:lppl1.3+)))
(define-public texlive-hycolor