aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 12:54:37 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:28 +0000
commitc5a45b3a8fe3887c853dc30af0ead6c47cc139de (patch)
tree478ac1e077037c5301f136da42f984f236144f2d /gnu
parent52ad47b9cb0c108f83ab0dd6416897a32ab8f88b (diff)
downloadguix-c5a45b3a8fe3887c853dc30af0ead6c47cc139de.tar.gz
guix-c5a45b3a8fe3887c853dc30af0ead6c47cc139de.zip
gnu: python-pytest-flask: Update to 1.3.0.
* gnu/packages/python-check.scm (python-pytest-flask): Update to 1.3.0. [build-system]: Swap to pyproject-build-system. [propagated-inputs]: Add python-flask. [native-inputs]: Remove python-flask and python-werkzeug; add python-setuptools and python-wheel. Change-Id: I73beecdcb9b954cc406fbfb7cac3cb4614c299ae
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index e4e5c583b6..a29352b531 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1815,18 +1815,21 @@ also ensuring that the notebooks are running without errors.")
(define-public python-pytest-flask
(package
(name "python-pytest-flask")
- (version "1.0.0")
+ (version "1.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-flask" version))
(sha256
- (base32
- "1hln7mwgdzfi5ma0kqfsi768l7p24jhkw8l0imhifwy08nh7hmjd"))))
- (build-system python-build-system)
+ (base32 "0pm93xli1pvq9w053grndi84hxq087mr2xhagvac98qvnabirgjq"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-flask python-pytest python-setuptools-scm
- python-werkzeug))
+ (list python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-flask))
(home-page "https://github.com/pytest-dev/pytest-flask")
(synopsis "Pytest fixtures to test Flask applications")
(description