aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-29 17:02:27 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-29 17:02:27 +0800
commitc5421392081944d43db18fe04eafecec521f994a (patch)
tree8cc38611cc3c0b4247003e24b72a42064c1ae143 /gnu
parent5c69f08f2e9f1c31ea1d88c39875237208ddfa03 (diff)
downloadguix-c5421392081944d43db18fe04eafecec521f994a.tar.gz
guix-c5421392081944d43db18fe04eafecec521f994a.zip
gnu: xorgxrdp: Switch to git source.
* gnu/packages/rdesktop.scm (xorgxrdp)[source]: Switch to git-fetch. [native-inputs]: Add autoconf, automake and libtool. Change-Id: I6ff0b7f76c750ab932aa3ffd5997c70479644b8d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rdesktop.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 0686f29f08..8024156417 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -232,13 +232,14 @@ variety of RDP clients:
(name "xorgxrdp")
(version "0.10.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/neutrinolabs/xorgxrdp/releases/download/v"
- version "/xorgxrdp-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/neutrinolabs/xorgxrdp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "125zn8xzppmf07wgdm4kw2w8ri4fbraca8r59fgibb1m6dqggsxm"))))
+ "1dcxn0v88426j4n7irhy6h3qb21202v5xs1vr7j8xvs3sxihc2f7"))))
(build-system gnu-build-system)
(inputs (list check
imlib2
@@ -254,8 +255,11 @@ variety of RDP clients:
xdpyinfo
xorg-server
xrdp))
- (native-inputs (list nasm
+ (native-inputs (list autoconf
+ automake
intltool
+ libtool
+ nasm
pkg-config
pixman))
(arguments
ions): Remove 'build-mode'; add 'validate-reconfigure'. (perform-action): Add #:validate-reconfigure. Call 'check-forward-update' when ACTION is 'reconfigure. (process-action): Pass #:validate-reconfigure to 'perform-action'. * gnu/home/services.scm (home-provenance): Export. * doc/guix.texi (Invoking guix home): Document '--allow-downgrades'. Ludovic Courtès 2022-01-28doc: Mention how to remedy "source file ... newer than compiled error"....* doc/contributing.texi (Running Guix Before It Is Installed): Mention how to remedy "source file ... newer than compiled" error by running `make -j`. Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Co-authored-by: Ryan Prior <rprior@protonmail.com> Co-authored-by: Blake Shaw <blake@nonconstructivism.com> Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Guix Together 2022-01-28doc: Explain the use of make clean-go when an ABI mismatch occurs....* doc/contributing.texi (Building from Git): Adds section on using make clean-go. Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Co-authored-by: Ryan Prior <rprior@protonmail.com> Co-authored-by: Blake Shaw <blake@nonconstructivism.com> Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Guix Together 2022-01-25doc: Document 'invoke' & co....* doc/guix.texi (Build Utilities)[Program Invocation]: New subsection. Ludovic Courtès 2022-01-25build: Require Guile >= 3.0.3....Fixes <https://issues.guix.gnu.org/53157>. Reported by Efraim Flashner <efraim@flashner.co.il>. * configure.ac: Require Guile >= 3.0.3. * doc/guix.texi (Requirements): Update accordingly. Ludovic Courtès 2022-01-24doc: Clarify search path bits....Suggested by Maxime Devos <maximedevos@telenet.be> and Maxim Cournoyer <maxim.cournoyer@gmail.com>. * doc/guix.texi (package Reference): Clarify 'native-search-paths' vs. 'search-paths'. (Search Paths): Link to it. Remove unnecessarily "define libxml2". Reword 'file-pattern' description that said "When true". Ludovic Courtès 2022-01-23doc: Tweak Guix Home bits....* doc/guix.texi (Shepherd Home Service): Tweak section name. Add intro. (Invoking guix home): Refer to "guix search". Use @var where appropriate. Ludovic Courtès 2022-01-23doc: Document search paths....* doc/guix.texi (package Reference): Link to "Search Paths". (Invoking guix package): Likewise. (Build Phases): Mention 'set-paths' phase. (Search Paths): New node. Ludovic Courtès 2022-01-20services: guix-publish: Add negative-ttl parameter....* gnu/services/base.scm (guix-publish-configuration): Add 'negative-ttl' field. (guix-publish-sheperd-service): Process it. * doc/guix.texi (Base Services)[guix-publish-service-type]: Add item for negative-ttl. Guillaume Le Vaillant 2022-01-19doc: Normalize language codes in menu URLs....* doc/build.scm (stylized-html)[build](base-language-url): Add calls to 'normalize'. Ludovic Courtès 2022-01-19doc: Make the HTML language menu disappear on narrow screens....* doc/build.scm (stylized-html)[build](navigation-bar): New procedure. (stylized-html): Use it. Ludovic Courtès 2022-01-18doc: Add a language menu in the HTML manual....* doc/build.scm (stylized-html): New procedure. (html-manual): Use it. Ludovic Courtès 2022-01-18doc: Factorize 'language-code->native-name'....* doc/build.scm (localization-helper-module)[content](translate): Add call to 'setenv' before 'write'. Remove use of 'with-language'. (language-code->native-name): New procedure. (html-manual-indexes)[build](top-level-index): Use it. Ludovic Courtès 2022-01-18daemon: Always default to gzip for log compression....* nix/libstore/globals.cc (Settings::Settings): Have 'logCompression' default to COMPRESSION_GZIP unconditionally. * gnu/services/base.scm (<guix-configuration>)[log-compression]: Default to 'gzip. * doc/guix.texi (Invoking guix-daemon, Base Services): Adjust accordingly. Ludovic Courtès 2022-01-18doc: Extract (localization) module....* doc/build.scm (localization-helper-module): New procedure. (html-manual-indexes)[build]: Use it. Remove use of GUILE-JSON-3. Ludovic Courtès 2022-01-16machine: ssh: Add 'safety-checks?' field....Fixes <https://issues.guix.gnu.org/52766>. Reported by Michael Rohleder <mike@rohleder.de>. * gnu/machine/ssh.scm (<machine-ssh-configuration>)[safety-checks?]: New field. (machine-check-file-system-availability): Return the empty list when 'safety-checks?' is false. (machine-check-initrd-modules): Likewise. * doc/guix.texi (Invoking guix deploy): Document it. Ludovic Courtès 2022-01-16doc: Fix typo....Groan. * doc/guix.texi (Build Environment Setup): Fix typo. Leo Famulari