aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2024-08-28 23:27:27 +0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-08-31 15:04:42 +0200
commitc48ae8acfcd61da36d14f0d5fe8af01f14d3561c (patch)
tree4cc05e03e3e70b02614e59d4851b23c44e0784b9 /gnu
parent9ea5ec1b8ca14caeb07d3bb7a77b431ee2c092a5 (diff)
downloadguix-c48ae8acfcd61da36d14f0d5fe8af01f14d3561c.tar.gz
guix-c48ae8acfcd61da36d14f0d5fe8af01f14d3561c.zip
gnu: Add c-template-sort.
* gnu/packages/c.scm (c-template-sort): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/c.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 87d3df193e..62234d3c9a 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -715,6 +715,42 @@ any other grammar rules.")
expressions.")
(license license:lgpl2.1+)))
+(define-public c-template-sort
+ ;; The latest commit is used as there is no release.
+ (let ((commit "24f5b8b13810ad130109c7b56daf8e99ab0fe1b8")
+ (revision "0"))
+ (package
+ (name "c-template-sort")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swenson/sort")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q3pgw51rjq7pb6gc7zx9i48pckyl930lcab4ngxrpa5a8flq850"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("sort.h" "include/sort.h")
+ ("sort_extra.h" "include/sort_extra.h"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "test"
+ (string-append "CC=" #$(cc-for-target)))))))))
+ (home-page "https://github.com/swenson/sort")
+ (synopsis "C implementation of many sorting algorithms")
+ (description "This package provides a header-only C library,
+that implements several sorting algorithms. It is configured using
+macros and supports user-defined types.")
+ (license license:expat))))
+
(define-public sparse
(package
(name "sparse")