aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-12 13:13:55 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:49 +0100
commitc3327150190f2e678c2d7c35637e4cbf8aed737d (patch)
treec8fd537cf5ae8a249800f48fea67d3524844d219 /gnu
parentc090f335dc95fe65d9a74be461e54f84f3d67bdc (diff)
downloadguix-c3327150190f2e678c2d7c35637e4cbf8aed737d.tar.gz
guix-c3327150190f2e678c2d7c35637e4cbf8aed737d.zip
gnu: go-golang-org-x-mod: Fix indentation.
* gnu/packages/golang-build.scm (go-golang-org-x-mod): Fix indentation. Change-Id: Ifb8aee1d0a38698155707a89cb02f9c726d03f52
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-build.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 92ff4cd9b9..d55fe2ac19 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -241,36 +241,36 @@ compile does not support generics.")
(license license:bsd-3)))
(define-public go-golang-org-x-mod
- (package
- (name "go-golang-org-x-mod")
- (version "0.19.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/golang/mod")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "02wilb8q2bp6qhqcrbjxq1pjy3y5k8p11pxlg481609zx4rjiszc"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/mod/"
- #:tests? #f
- #:phases (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (home-page "https://golang.org/x/mod")
- (synopsis "Tools to work directly with Go module mechanics")
- (description
- "This repository holds packages for writing tools that work directly
+ (package
+ (name "go-golang-org-x-mod")
+ (version "0.19.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/mod")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02wilb8q2bp6qhqcrbjxq1pjy3y5k8p11pxlg481609zx4rjiszc"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/mod/"
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (home-page "https://golang.org/x/mod")
+ (synopsis "Tools to work directly with Go module mechanics")
+ (description
+ "This repository holds packages for writing tools that work directly
with Go module mechanics. That is, it is for direct manipulation of Go
modules themselves.
The specific case of loading packages should still be done by invoking the
@command{go} command, which remains the single point of truth for package
loading algorithms.")
- (license license:bsd-3)))
+ (license license:bsd-3)))
(define-public go-golang-org-x-net
(let ((commit "8e0e7d8d38f2b6d21d742845570dde2902d06a1d")