aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHomo <gay@disroot.org>2024-12-16 10:47:32 +0200
committerLudovic Courtès <ludo@gnu.org>2024-12-23 20:45:33 +0100
commitc302b7a5966908b3a5db1ef3ccd3af460b847675 (patch)
tree4bba8850fb9b833f77b91362d2e45ae080238553 /gnu
parent8636854d18d29f7638d5f55d1f7bd3c170585e70 (diff)
downloadguix-c302b7a5966908b3a5db1ef3ccd3af460b847675.tar.gz
guix-c302b7a5966908b3a5db1ef3ccd3af460b847675.zip
gnu: hugs: Fix build with GCC.
* gnu/packages/patches/hugs-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/hugs.scm (hugs)[source]: Use it. [native-inputs]: Remove. Change-Id: I8b17f6c8a89fbc25ac9fe40b58962c83b08cbc21 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/hugs.scm7
-rw-r--r--gnu/packages/patches/hugs-fix-build.patch24
3 files changed, 28 insertions, 4 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1578745c4f..17839bfffc 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1567,6 +1567,7 @@ dist_patch_DATA = \
%D%/packages/patches/htslib-for-stringtie.patch \
%D%/packages/patches/hubbub-sort-entities.patch \
%D%/packages/patches/hueplusplus-mbedtls.patch \
+ %D%/packages/patches/hugs-fix-build.patch \
%D%/packages/patches/hurd-64bit.patch \
%D%/packages/patches/hurd-refcounts-assert.patch \
%D%/packages/patches/hurd-rumpdisk-no-hd.patch \
diff --git a/gnu/packages/hugs.scm b/gnu/packages/hugs.scm
index c9915e4cd6..b6a97ea78c 100644
--- a/gnu/packages/hugs.scm
+++ b/gnu/packages/hugs.scm
@@ -23,7 +23,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages gcc))
+ #:use-module (gnu packages))
(define-public hugs
(package
@@ -36,7 +36,8 @@
name "98-plus-" version ".tar.gz"))
(sha256
(base32
- "1mdy4aq4campgmnpc2qwq7bsbfhaxfsqdghbyyz2wms4lnfcmyma"))))
+ "1mdy4aq4campgmnpc2qwq7bsbfhaxfsqdghbyyz2wms4lnfcmyma"))
+ (patches (search-patches "hugs-fix-build.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -71,8 +72,6 @@
(("/bin/cp") (which "cp")))
#t)))
#:tests? #f)) ; no test target
- ;; FIXME: Fails to build with GCC 5.
- (native-inputs (list gcc-4.9))
(home-page "https://www.haskell.org/hugs/")
(synopsis "Functional programming system based on Haskell 98")
(description
diff --git a/gnu/packages/patches/hugs-fix-build.patch b/gnu/packages/patches/hugs-fix-build.patch
new file mode 100644
index 0000000000..2c053e18d0
--- /dev/null
+++ b/gnu/packages/patches/hugs-fix-build.patch
@@ -0,0 +1,24 @@
+Fixes build with GCC 5 and later.
+Patch from <https://aur.archlinux.org/cgit/aur.git/tree/hsbase_inline.patch?h=hugs>.
+
+diff --git a/packages/base/include/HsBase.h b/packages/base/include/HsBase.h
+index aa1a7fb..78d5b46 100644
+--- a/packages/base/include/HsBase.h
++++ b/packages/base/include/HsBase.h
+@@ -217,15 +217,7 @@ StgWord64 stg_integerToWord64 (StgInt sa, StgByteArray /* Really: mp_limb_t* */
+ when compiling to native code.
+ -------------------------------------------------------------------------- */
+
+-#ifndef INLINE
+-# if defined(_MSC_VER)
+-# define INLINE extern __inline
+-# elif defined(__GNUC__)
+-# define INLINE extern inline
+-# else
+-# define INLINE inline
+-# endif
+-#endif
++#define INLINE inline
+
+ INLINE int __hscore_get_errno(void) { return errno; }
+ INLINE void __hscore_set_errno(int e) { errno = e; }