aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:28 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:17:36 +0100
commitc08ab74432b5baa548edc3a081b30d29f183d1f7 (patch)
treefd7627eebe9ea74b684053e6efe3a6368e39091f /gnu
parentabffb41c097ce2277b4220f9bd5660fc75b3f0ab (diff)
downloadguix-c08ab74432b5baa548edc3a081b30d29f183d1f7.tar.gz
guix-c08ab74432b5baa548edc3a081b30d29f183d1f7.zip
gnu: perl-text-balanced: Update to 1.75.
* gnu/packages/perl.scm (perl-text-balanced): Update to 1.75. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 344bedb96a..c82c3a4304 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11445,6 +11445,32 @@ into tables.")
used to justify strings to various alignment styles.")
(license license:x11)))
+(define-public perl-text-autoformat
+ (package
+ (name "perl-text-autoformat")
+ (version "1.75")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/N/NE/NEILB/Text-Autoformat-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0wdpqq1cds68i1clx2y22bnnm558d12sr7dmypdv9i5f7p7g9m4x"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-text-reform))
+ (home-page "https://metacpan.org/release/Text-Autoformat")
+ (synopsis "Automatic text wrapping and reformatting")
+ (description
+ "The fundamental task of the autoformat subroutine is to identify and
+rearrange independent paragraphs in a text. Paragraphs typically consist of a
+series of lines containing at least one non-whitespace character, followed by
+one or more lines containing only optional whitespace. This is a more liberal
+definition than many other formatters use: most require an empty line to
+terminate a paragraph. Paragraphs may also be denoted by bulleting, numbering,
+or quoting (see the following sections).")
+ (license license:perl-license)))
+
(define-public perl-text-balanced
(package
(name "perl-text-balanced")