aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-01-20 22:59:08 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:38 +0200
commitbe86f3de1eb175ba3e17f2146f2c96849f4f4fe7 (patch)
tree34f36f87574ab0c81699872ceff85f4cb1561ac7 /gnu
parent3de22656adbfa62362f735d8e137311a62ded856 (diff)
downloadguix-be86f3de1eb175ba3e17f2146f2c96849f4f4fe7.tar.gz
guix-be86f3de1eb175ba3e17f2146f2c96849f4f4fe7.zip
gnu: python: Make the build reproducible.
While Python build was reproducible on a single machine, once multiple file systems entered the picture, it was no longer true. The solution adopted by the upstream (and Debian) was cherry-picked. More info: <https://github.com/python/cpython/pull/8226>. * gnu/packages/python.scm (python-3.10) [source]: Apply reproducibility patch. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I0273dc0f8511a7acdcc2b462a26cc29a9756c801
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-3-reproducible-build.patch30
-rw-r--r--gnu/packages/python.scm1
3 files changed, 32 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8e8ae76e23..2e664beaa9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1970,6 +1970,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-hurd-configure.patch \
%D%/packages/patches/python-angr-addition-type-error.patch \
%D%/packages/patches/python-angr-check-exec-deps.patch \
+ %D%/packages/patches/python-3-reproducible-build.patch \
%D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \
%D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \
%D%/packages/patches/python-cross-compile.patch \
diff --git a/gnu/packages/patches/python-3-reproducible-build.patch b/gnu/packages/patches/python-3-reproducible-build.patch
new file mode 100644
index 0000000000..12bd8de7c2
--- /dev/null
+++ b/gnu/packages/patches/python-3-reproducible-build.patch
@@ -0,0 +1,30 @@
+From 6c8ea7c1dacd42f3ba00440231ec0e6b1a38300d Mon Sep 17 00:00:00 2001
+From: Inada Naoki <songofacandy@gmail.com>
+Date: Sat, 14 Jul 2018 00:46:11 +0900
+Subject: [PATCH] Use FLAG_REF always for interned strings
+
+---
+ Python/marshal.c | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/Python/marshal.c b/Python/marshal.c
+index 6d06266c6a8e2e..51db2e3b2e29a2 100644
+--- a/Python/marshal.c
++++ b/Python/marshal.c
+@@ -275,9 +275,14 @@ w_ref(PyObject *v, char *flag, WFILE *p)
+ if (p->version < 3 || p->hashtable == NULL)
+ return 0; /* not writing object references */
+
+- /* if it has only one reference, it definitely isn't shared */
+- if (Py_REFCNT(v) == 1)
++ /* If it has only one reference, it definitely isn't shared.
++ * But we use TYPE_REF always for interned string, to PYC file stable
++ * as possible.
++ */
++ if (Py_REFCNT(v) == 1 &&
++ !(PyUnicode_CheckExact(v) && PyUnicode_CHECK_INTERNED(v))) {
+ return 0;
++ }
+
+ entry = _Py_HASHTABLE_GET_ENTRY(p->hashtable, v);
+ if (entry != NULL) {
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b2757c651e..6272489afb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -435,6 +435,7 @@ data types.")
"python-3-deterministic-build-info.patch"
"python-3-fix-tests.patch"
"python-3-hurd-configure.patch"
+ "python-3-reproducible-build.patch"
"python-3-search-paths.patch"))
(sha256
(base32