aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:08 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:07:17 +0100
commitbe311533902900f16ff58cc18061ca4522441033 (patch)
tree5b48d2f19c9b3f3344645c76062dafd87c6ec0f6 /gnu
parentcdca7347756e4ae230bbe2d6795451e649bc634e (diff)
downloadguix-be311533902900f16ff58cc18061ca4522441033.tar.gz
guix-be311533902900f16ff58cc18061ca4522441033.zip
gnu: Add ocaml-hmap.
* gnu/packages/ocaml.scm (ocaml-hmap): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1d30eadd92..4a45f5f73b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2770,6 +2770,32 @@ architectures and provide a best-effort boxed representation on 32-bit
architectures.")
(license license:isc)))
+(define-public ocaml-hmap
+ (package
+ (name "ocaml-hmap")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://erratique.ch/software/hmap/releases/hmap-0.8.1.tbz")
+ (sha256
+ (base32 "10xyjy4ab87z7jnghy0wnla9wrmazgyhdwhr4hdmxxdn28dxn03a"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:build-flags
+ (list "build" "--tests" "true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list ocaml-topkg ocamlbuild opam))
+ (home-page "https://erratique.ch/software/hmap")
+ (synopsis "Heterogeneous value maps for OCaml")
+ (description
+ "Hmap provides heterogeneous value maps for OCaml. These maps bind keys to
+values with arbitrary types. Keys witness the type of the value they are bound
+to which allows adding and looking up bindings in a type safe manner.")
+ (license license:isc)))
+
(define-public ocaml-lwt
(package
(name "ocaml-lwt")
puts' to `(or native-inputs inputs)' when searching for `docbook-xsl' path. Signed-off-by: Marius Bakke <marius@gnu.org> Jean-Pierre De Jesus DIAZ 2022-06-16gnu: polkit-qt: Update to 1-0.114.0....* gnu/packages/polkit.scm (polkit-qt): Update to 1-0.114.0. [source]: Update to new source URI. Efraim Flashner 2022-06-01Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner 2022-05-31gnu: mozjs: Cleanup to only keep the last version....* gnu/packages/gnuzilla.scm (mozjs): Preserve only the metadata and otherwise update fields to use those of mozjs-78. [arguments]: Use gexps. [phases]: Delete trailing #t. [native-inputs]: Use new style. (mozjs-38, mozjs-52, mozjs-60, mozjs-78): Delete variables. * gnu/packages/patches/mozjs17-aarch64-support.patch * gnu/packages/patches/mozjs24-aarch64-support.patch * gnu/packages/patches/mozjs38-pkg-config-version.patch * gnu/packages/patches/mozjs38-shell-version.patch * gnu/packages/patches/mozjs38-tracelogger.patch * gnu/packages/patches/mozjs38-version-detection.patch * gnu/packages/patches/mozjs60-riscv64-support.patch: Delete patches. * gnu/local.mk (dist_patch_DATA): De-register them. * gnu/packages/games.scm (0ad): Adjust accordingly. * gnu/packages/gnome.scm (gjs): Likewise. * gnu/packages/polkit.scm (polkit-mozjs): Likewise. Maxim Cournoyer 2022-05-11gnu: polkit: Remove input labels....* gnu/packages/polkit.scm (polkit-mozjs)[native-inputs]: Remove labels. (polkit-duktape)[native-inputs, inputs]: Use 'modify-inputs'. Ludovic Courtès 2022-05-11gnu: polkit: Incorporate security fix and remove replacement....* gnu/packages/polkit.scm (polkit-mozjs)[replacement]: Remove. [source]: Add "polkit-CVE-2021-4034.patch". (polkit-mozjs/fixed): Remove. Ludovic Courtès 2022-01-26gnu: polkit: Fix CVE-2021-4034....* gnu/packages/patches/polkit-CVE-2021-4034.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/polkit.scm (polkit-mozjs)[replacement]: New field. * gnu/packages/polkit.scm (polkit-mozjs/fixed): New variable. Ludovic Courtès