aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-14 11:28:17 -0300
committerVinicius Monego <monego@posteo.net>2024-07-28 10:49:17 -0300
commitbd03b42d916c1b8194e9d4b7f43f94faf841b652 (patch)
treeea1291067bd609780abf2be718727bf06716c412 /gnu
parentb556eee0f1ffa91c074162457f3a9c0c868f4473 (diff)
downloadguix-bd03b42d916c1b8194e9d4b7f43f94faf841b652.tar.gz
guix-bd03b42d916c1b8194e9d4b7f43f94faf841b652.zip
gnu: libngspice, ngspice: Update to 43.
* gnu/packages/engineering.scm (libngspice, ngspice): Update to 43. (libngspice)[arguments]<#:phases>: Delete the 'patch-timestamps and 'delete-program-manuals phases. (ngspice)[arguments]<#:phases>: Delete the 'delete-include-files phase. Remove the line that deletes the now deleted 'delete-program-manuals phase. These substitutions do not apply anymore. Change-Id: Ie7ec8dd0998df38828e2e0af226158922e34ea09
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 4e465ddb7d..e4db4da957 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1979,7 +1979,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27344#236>.
(package
(name "libngspice")
- (version "42")
+ (version "43")
(source
(origin
(method url-fetch)
@@ -1990,7 +1990,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
"old-releases/" version
"/ngspice-" version ".tar.gz")))
(sha256
- (base32 "02p5ar1cqwn70dw5xzx5v3qhm1p1xgb1xpzs1ljklcxjda2f6zvk"))))
+ (base32 "169nn6bw5628m2k8cy77yd1vs22plj83grisq58j07sk11pnmp8l"))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.
@@ -1998,15 +1998,6 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-timestamps
- (lambda _
- (substitute* "configure"
- (("`date`") "Thu Jan 1 00:00:01 UTC 1970"))))
- (add-after 'unpack 'delete-program-manuals
- (lambda _
- (substitute* "man/man1/Makefile.in"
- (("^man_MANS = ngspice\\.1 ngnutmeg\\.1 ngsconvert\\.1 ngmultidec\\.1")
- "man_MANS = "))))
(add-after 'install 'delete-scripts
(lambda* (#:key outputs #:allow-other-keys)
(delete-file-recursively
@@ -2044,12 +2035,6 @@ an embedded event driven algorithm.")
(delete "--with-ngshared" ,flags)))
((#:phases phases)
`(modify-phases ,phases
- (add-after 'unpack 'delete-include-files
- (lambda _
- (substitute* "src/Makefile.in"
- (("^SUBDIRS = misc maths frontend spicelib include/ngspice")
- "SUBDIRS = misc maths frontend spicelib"))))
- (delete 'delete-program-manuals)
(delete 'delete-scripts)))))
(inputs
(list libngspice readline))))