aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:40:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:39 +0200
commitbcbf90763945eb09885a7c9b605b3ab8e6b2a1f1 (patch)
tree56da393f3cb97b3a7b97565f05b1288ae3d599b4 /gnu
parent2d44d383ed65f712627682d241d9b0a6a18dce28 (diff)
downloadguix-bcbf90763945eb09885a7c9b605b3ab8e6b2a1f1.tar.gz
guix-bcbf90763945eb09885a7c9b605b3ab8e6b2a1f1.zip
gnu: Add texlive-pxpic.
* gnu/packages/tex.scm (texlive-pxpic): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3f2a69c202..6f1ee2473f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3575,6 +3575,27 @@ connections under e-pTeX and @code{dvipdfmx}. The package uses existing
features of @code{dvipdfmx} to fix this problem.")
(license license:expat)))
+(define-public texlive-pxpic
+ (package
+ (name "texlive-pxpic")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pxpic/" "source/latex/pxpic/"
+ "tex/latex/pxpic/")
+ (base32
+ "01k4c7fakc2wjbjasxqm9gnzhchn2bqnj3vvz5rrcxiq0wibmiyi")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pxpic")
+ (synopsis "Draw pixel pictures")
+ (description
+ "With @code{pxpic} you draw pictures pixel by pixel. It was inspired by
+a lovely post by Paulo Cereda, among other things (most notably a beautiful
+duck) showcasing the use of characters from the Mario video games by Nintendo
+in LaTeX.")
+ (license license:lppl1.3c)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")