aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2023-04-29 01:43:15 -0400
committerLudovic Courtès <ludo@gnu.org>2023-05-19 16:46:35 +0200
commitbac28a52cb7cbc42d7fabbce0e47028367e69a61 (patch)
treea76c240154dbfe688d76ed2c178a05650bfd6e4b /gnu
parent6e80fa2f3cb86f662f03dfd613c9d943bb9c913f (diff)
downloadguix-bac28a52cb7cbc42d7fabbce0e47028367e69a61.tar.gz
guix-bac28a52cb7cbc42d7fabbce0e47028367e69a61.zip
gnu: python-cssutils: Update to 2.6.0.
Resending second patch with a better commit message. * gnu/packages/python-web.scm (python-cssutils): Update to 2.6.0. [build-system]: Switch to pyproject-build-system. [arguments]: Enable tests. [native-inputs]: Remove unzip; add python-pytest and python-jaraco-test. [homepage]: Update it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm33
1 files changed, 21 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index dbd6e98730..b6ad489626 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1978,20 +1978,29 @@ for clients and servers.")
(define-public python-cssutils
(package
(name "python-cssutils")
- (version "1.0.2")
+ (version "2.6.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "cssutils" version))
- (sha256
- (base32
- "1bxchrbqzapwijap0yhlxdil1w9bmwvgx77aizlkhc2mcxjg1z52"))))
- (build-system python-build-system)
- (native-inputs
- (list unzip)) ; for unpacking the source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cssutils" version))
+ (sha256
+ (base32
+ "13l1y0xr3fgbl95w3pinb5av5dqk2ip39pih6vgrz47c3hyd5p7p"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:tests? #f)) ; tests require python-pbr < 1.7.0
- (home-page "https://cthedot.de/cssutils/")
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv" "-k"
+ ;; disable tests requiring network
+ (string-append "not test_parseUrl "
+ "and not encutils "
+ "and not website.logging")))))))
+ (native-inputs
+ (list python-pytest python-jaraco-test))
+ (home-page "https://github.com/jaraco/cssutils")
(synopsis
"CSS Cascading Style Sheets library for Python")
(description