aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:42:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:59 +0200
commitba7dd1f2d0645990e763a77859b81effd70c933f (patch)
tree18eb26c275881120e0b0ad8a71d2b22f39e1380e /gnu
parent5aae12e6191edcfff233e4d4e297015b81fe7b2f (diff)
downloadguix-ba7dd1f2d0645990e763a77859b81effd70c933f.tar.gz
guix-ba7dd1f2d0645990e763a77859b81effd70c933f.zip
gnu: Add texlive-tikz-trackschematic.
* gnu/packages/tex.scm (texlive-tikz-trackschematic): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b9850d89d0..b7dfb38200 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4871,6 +4871,30 @@ produce the graphics. A tabular-like environment is provided to produce
larger timing diagrams.")
(license license:lppl)))
+(define-public texlive-tikz-trackschematic
+ (package
+ (name "texlive-tikz-trackschematic")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikz-trackschematic/"
+ "tex/latex/tikz-trackschematic/")
+ (base32
+ "11dak88q9n54i385sjk4nxini2fycdfmhs2h41fdf9k2012ykdnx")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikz-trackschematic")
+ (synopsis "TikZ library for creating track diagrams in railways")
+ (description
+ "This TikZ library is a toolbox of symbols geared primarily towards
+creating track schematic for either research or educational purposes. It
+provides a TikZ frontend to some of the symbols which may be needed to
+describe situations and layouts in railway operation. The library is divided
+into sublibraries: @code{topology}, @code{trafficcontrol}, @code{vehicles},
+@code{constructions}, @code{electrics}, @code{symbology}, and
+@code{measures}.")
+ (license license:isc)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")