aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-12-16 00:09:19 -0600
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-16 18:34:17 +0100
commitba48c89ab96044ff60b8ed2310dc08cc84409c29 (patch)
tree7e6ca5b81a0b934b673bddf9dc50378b80740e85 /gnu
parent587716149913a4c88612884c709c44d3736d5769 (diff)
downloadguix-ba48c89ab96044ff60b8ed2310dc08cc84409c29.tar.gz
guix-ba48c89ab96044ff60b8ed2310dc08cc84409c29.zip
gnu: Add emacs-eglot-tempel.
* gnu/packages/emacs-xyz.scm (emacs-eglot-tempel): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4a93093cdb..839668e848 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10234,6 +10234,29 @@ provides a front-end interface for the workspace/symbols LSP procedure
call.")
(license license:gpl3+)))
+(define-public emacs-eglot-tempel
+ (let ((commit "e08b203d6a7c495d4b91ed4537506b5f1ea8a84f")
+ (revision "0"))
+ (package
+ (name "emacs-eglot-tempel")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fejfighter/eglot-tempel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f4m0bb1f91x9jqfc0ny95a3pfh1mzzjzdjpa6f548hynq8j34ib"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-eglot emacs-tempel))
+ (home-page "https://github.com/fejfighter/eglot-tempel")
+ (synopsis "Bridge for Tempel templates with Eglot")
+ (description "This package is an adapter to use the Tempel templating
+library with Eglot instead of Yasnippet.")
+ (license license:gpl3+))))
+
(define-public emacs-consult-yasnippet
(let ((commit "ae0450889484f23dc4ec37518852a2c61b89f184")
(revision "0"))