aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRodion Goritskov <rodion.goritskov@gmail.com>2024-02-28 01:03:44 +0400
committerAndreas Enge <andreas@enge.fr>2024-02-29 19:19:24 +0100
commitb988248e1c88bde3001b7f2b1830dececa7e8b23 (patch)
tree32b34a3dd3e19dec8a6c90c25ff8208615c2d89c /gnu
parent9ca2161ef43c43b2f52c4b8fc51d6bc882b04b76 (diff)
downloadguix-b988248e1c88bde3001b7f2b1830dececa7e8b23.tar.gz
guix-b988248e1c88bde3001b7f2b1830dececa7e8b23.zip
gnu: clifm: Update to 1.17.
* gnu/packages/clifm.scm (clifm): Update to 1.17. [description]: Correct a typo. Change-Id: I16ff527138654e7a25f778beabf2aba38dda1056 Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/clifm.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/clifm.scm b/gnu/packages/clifm.scm
index c5610c1afc..983a23b80a 100644
--- a/gnu/packages/clifm.scm
+++ b/gnu/packages/clifm.scm
@@ -30,7 +30,7 @@
(define-public clifm
(package
(name "clifm")
- (version "1.16")
+ (version "1.17")
(source
(origin
(method git-fetch)
@@ -39,7 +39,7 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ddg6d4y4kfjk34j0fb7nij5vi5m69vv48knv7j1plbhzqk6qg5n"))))
+ (base32 "00f5x0352dsf8f9ixkcwma7wr5pg78maavmd950nni38m647clm6"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list (string-append "CC="
@@ -53,8 +53,8 @@
(inputs (list readline acl libcap))
(home-page "https://github.com/leo-arch/clifm")
(synopsis "Command-line file manager")
- (description "Clifm a shell-like, text-based terminal file manager that
-sits on the command line.
+ (description "Clifm is a shell-like, text-based terminal file manager
+that sits on the command line.
It is built with command line principles in mind: instead of navigating
through a big menu of files, it lets you type, exactly as you do in your
s a scope variable
+ var redef = node.definition().redefined();
+ if (redef) redef.const_redefs = true;
}
- return true;
- }
- // ensure compression works if `const` reuses a scope variable
- if (node instanceof AST_SymbolConst) {
- var redef = node.definition().redefined();
- if (redef) redef.const_redefs = true;
+ if (node.name != "arguments") return true;
+ var parent = node instanceof AST_SymbolVar && tw.parent();
+ if (parent instanceof AST_VarDef && !parent.value) return true;
+ var sym = node.scope.resolve().find_variable("arguments");
+ if (sym && is_arguments(sym)) sym.scope.uses_arguments = 3;
return true;
}
if (node instanceof AST_SymbolRef) {
@@ -295,13 +300,6 @@ AST_Toplevel.DEFMETHOD("figure_out_scope", function(options) {
node.reference(options);
return true;
}
- if (node instanceof AST_VarDef) {
- if (node.value && node.name.name == "arguments") {
- var sym = node.name.scope.resolve().find_variable("arguments");
- if (sym && is_arguments(sym)) sym.scope.uses_arguments = 3;
- }
- return;
- }
});
self.walk(tw);
diff --git a/test/compress/destructured.js b/test/compress/destructured.js
index 4f6a9f2f..029b4427 100644
--- a/test/compress/destructured.js
+++ b/test/compress/destructured.js
@@ -2189,7 +2189,7 @@ issue_4446: {
issue_4456: {
options = {
- pure_getters: true,
+ pure_getters: "strict",
unused: true,
}
input: {
@@ -2398,3 +2398,61 @@ issue_4512: {
expect_stdout: "undefined"
node_version: ">=6"
}
+
+issue_4519_1: {
+ options = {
+ arguments: true,
+ keep_fargs: false,
+ }
+ input: {
+ try {
+ (function() {
+ var [ arguments ] = [];
+ arguments[0];
+ })();
+ } catch (e) {
+ console.log("PASS");
+ }
+ }
+ expect: {
+ try {
+ (function() {
+ var [ arguments ] = [];
+ arguments[0];
+ })();
+ } catch (e) {
+ console.log("PASS");
+ }
+ }
+ expect_stdout: "PASS"
+ node_version: ">=6"
+}
+
+issue_4519_2: {
+ options = {
+ pure_getters: "strict",
+ side_effects: true,
+ }
+ input: {
+ try {
+ (function() {
+ var [ arguments ] = [];
+ arguments[0];
+ })();
+ } catch (e) {
+ console.log("PASS");
+ }
+ }
+ expect: {
+ try {
+ (function() {
+ var [ arguments ] = [];
+ arguments[0];
+ })();
+ } catch (e) {
+ console.log("PASS");
+ }
+ }
+ expect_stdout: "PASS"
+ node_version: ">=6"
+}