aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrennan Vincent <brennan@umanwizard.com>2024-09-09 14:23:56 -0400
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:19 +0200
commitb78c6991e4da355c50517b8012d0719d2fc15cc0 (patch)
treec6587f8189e078e07975257e81c07fbe6437e9f0 /gnu
parent89d6561de9ffff2b24c74418564c1983c187508a (diff)
downloadguix-b78c6991e4da355c50517b8012d0719d2fc15cc0.tar.gz
guix-b78c6991e4da355c50517b8012d0719d2fc15cc0.zip
gnu: rust: Update to 1.81.
gnu/packages/rust.scm (rust-1.81): New variable. gnu/packages/rust.scm (rust): Update to 1.81. Change-Id: Idb1958364225bebb9aa415419083b6ab97d7c4c7 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 016ffced53..d0a62e8905 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -1050,6 +1050,10 @@ safety and thread safety guarantees.")
(("features = \\[\"fs\"" all)
(string-append all ", \"use-libc\""))))))))))
+(define-public rust-1.81
+ (rust-bootstrapped-package rust-1.80 "1.81.0"
+ "19yggj1qivdhf68gx2652cfi7nxjkdgy39wh7h6facpzppz4h947"))
+
(define (make-ignore-test-list strs)
"Function to make creating a list to ignore tests a bit easier."
(map (lambda (str)
@@ -1064,7 +1068,7 @@ safety and thread safety guarantees.")
;;; Here we take the latest included Rust, make it public, and re-enable tests
;;; and extra components such as rustfmt.
(define-public rust
- (let ((base-rust rust-1.80))
+ (let ((base-rust rust-1.81))
(package
(inherit base-rust)
(properties (append
@@ -1131,7 +1135,10 @@ safety and thread safety guarantees.")
'("fn fetch_downloads_with_git2_first_")))
(substitute* "src/tools/cargo/tests/testsuite/build.rs"
,@(make-ignore-test-list
- '("fn build_with_symlink_to_path_dependency_with_build_script_in_git")))))
+ '("fn build_with_symlink_to_path_dependency_with_build_script_in_git")))
+ (substitute* "src/tools/cargo/tests/testsuite/publish_lockfile.rs"
+ ,@(make-ignore-test-list
+ '("fn note_resolve_changes")))))
(add-after 'unpack 'disable-tests-requiring-mercurial
(lambda _
(with-directory-excursion "src/tools/cargo/tests/testsuite/cargo_init"
@@ -1219,7 +1226,12 @@ safety and thread safety guarantees.")
;; string "rustc"
,@(make-ignore-test-list
'("fn config_fingerprint"
- "fn features_fingerprint")))))
+ "fn features_fingerprint")))
+ (substitute* "src/tools/cargo/tests/testsuite/git_auth.rs"
+ ;; This checks for a specific networking error message
+ ;; that's different from the one we see in the builder
+ ,@(make-ignore-test-list
+ '("fn net_err_suggests_fetch_with_cli")))))
(add-after 'unpack 'patch-command-exec-tests
;; This test suite includes some tests that the stdlib's
;; `Command` execution properly handles in situations where