aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-05-02 10:55:29 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-05-02 11:10:38 +0200
commitb74f64a960542b0679ab13de0dd28adc496cf084 (patch)
tree71e41267e31a5f04796cf6a1daea1292974f87c5 /gnu
parentcba962086da190b474df4f55bf2b50278f519640 (diff)
downloadguix-b74f64a960542b0679ab13de0dd28adc496cf084.tar.gz
guix-b74f64a960542b0679ab13de0dd28adc496cf084.zip
gnu: Add r-xnomial.
* gnu/packages/statistics.scm (r-xnomial): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 2178984d04..3d0faf7572 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1828,6 +1828,34 @@ documents (including DTDs), both local and accessible via HTTP or FTP. Also
offers access to an XPath \"interpreter\".")
(license license:bsd-2)))
+(define-public r-xnomial
+ (package
+ (name "r-xnomial")
+ (version "1.0.4")
+ (source
+ (origin (method url-fetch)
+ (uri (cran-uri "XNomial" version))
+ (sha256
+ (base32
+ "1mwx302576rmsjllbq2clfxilm3hkyp5bw0wmwqbn0kgv5wpy8z6"))))
+ (properties (quasiquote ((upstream-name . "XNomial"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/XNomial")
+ (synopsis "Goodness-of-Fit test for multinomial data")
+ (description
+ "This package provides an exact Goodness-of-Fit test for
+multinomial data with fixed probabilities. It can be used to
+determine whether a set of counts fits a given expected ratio. To see
+whether a set of observed counts fits an expectation, one can examine
+all possible outcomes with @code{xmulti()} or a random sample of them
+with @code{xmonte()} and find the probability of an observation
+deviating from the expectation by at least as much as the observed.
+As a measure of deviation from the expected, one can use the
+log-likelihood ratio, the multinomial probability, or the classic
+chi-square statistic. A histogram of the test statistic can also be
+plotted and compared with the asymptotic curve.")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-lambda-r
(package
(name "r-lambda-r")
>2022-11-15doc: Build pt_BR manual....* doc/build.scm (%manual-languages): Add "pt_BR". Ludovic Courtès 2022-06-15doc: Use a minimal texlive profile in build.scm....* doc/build.scm (pdf-manual) <texinfo-profile>: New variable. <PATH>: Define in terms of the above. <GUIX_TEXMF>: New environment variable. Maxim Cournoyer 2022-04-08doc: Build an empty index if the manual is missing....That way, the "sk" index for 'guix-manual' is empty, because 'guix-manual' lacks an "sk" translation. * doc/build.scm (html-manual-identifier-index)[build](html-files): Gracefully handle 'scandir' returning #f. Ludovic Courtès 2022-04-08doc: Allow different translations for 'guix-cookbook' and 'guix-manual'....Previously, 'guix-manual-text-domain' could be passed the cookbook language list as its second argument. Thus, it started failing when the set of cookbook languages was no longer a subset of the manual languages, starting with commit 93bfd4d9c7ba7055c19f02128491b3a98a180860, which removed "sk" from 'guix-manual' but kept it for 'guix-cookbook'. * doc/build.scm (%manual-languages, %cookbook-languages): New variables. (%languages): Use them. (guix-manual-text-domain): Give LANGUAGES a valid default value. (localization-helper-module): Remove optional argument to 'guix-manual-text-domain'. Ludovic Courtès 2022-03-02doc: Publish the Slovak translation of the cookbook....* doc/build.scm (%languages): Add "sk" for "guix-cookbook" (it's currently at 57%). Ludovic Courtès 2022-01-19doc: Normalize language codes in menu URLs....* doc/build.scm (stylized-html)[build](base-language-url): Add calls to 'normalize'. Ludovic Courtès 2022-01-19doc: Make the HTML language menu disappear on narrow screens....* doc/build.scm (stylized-html)[build](navigation-bar): New procedure. (stylized-html): Use it. Ludovic Courtès 2022-01-18doc: Add a language menu in the HTML manual....* doc/build.scm (stylized-html): New procedure. (html-manual): Use it. Ludovic Courtès 2022-01-18doc: Factorize 'language-code->native-name'....* doc/build.scm (localization-helper-module)[content](translate): Add call to 'setenv' before 'write'. Remove use of 'with-language'. (language-code->native-name): New procedure. (html-manual-indexes)[build](top-level-index): Use it. Ludovic Courtès 2022-01-18doc: Extract (localization) module....* doc/build.scm (localization-helper-module): New procedure. (html-manual-indexes)[build]: Use it. Remove use of GUILE-JSON-3. Ludovic Courtès 2022-01-15doc: Remove now unnecessary workaround....* doc/build.scm (translated-texi-manuals): Turn into an alias for (@@ (guix self) translated-texi-manuals). Ludovic Courtès 2021-12-13Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-12-13doc: Handle '&nbsp' when syntax-highlighting HTML....* doc/build.scm (syntax-highlighted-html)[build](entity->string): Handle "&nbsp". Ludovic Courtès 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-28doc: Allow offloading of the expensive derivations....* doc/build.scm (translated-texi-manuals) (html-manual, pdf-manual): Pass #:local-build? #f. Ludovic Courtès 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-09doc: Build manual translations with 'guile-3.0-latest'....Fixes <https://bugs.gnu.org/47428>. Reported by Leo Famulari <leo@famulari.name>. * doc/build.scm (translated-texi-manuals): Explicitly use 'guile-3.0-latest'. Ludovic Courtès