aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-03 10:12:36 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:52 +0200
commitb57d46c7efa664b62b038b809e537fd12f57ce06 (patch)
treef9520f12b4ec674e2bc0a14ec7c6753b559cd67a /gnu
parent00ec4eb182d05759040b2d5e98385c481724f2bb (diff)
downloadguix-b57d46c7efa664b62b038b809e537fd12f57ce06.tar.gz
guix-b57d46c7efa664b62b038b809e537fd12f57ce06.zip
gnu: Add rust-typesize-0.1.
* gnu/packages/crates-io.scm (rust-typesize-0.1): New variable. Change-Id: I4c9f34a96403c3ab23785ac28a08d4981cd01674
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9f79bbdcbf..03716b6eb8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -87493,6 +87493,43 @@ implementation is incomplete.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-typesize-0.1
+ (package
+ (name "rust-typesize")
+ (version "0.1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "typesize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1nv4p49nyrrxf5zkbyzbzy2442jn3rh8h5slyjgnmbv8cb0fbv2x"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-arrayvec" ,rust-arrayvec-0.7)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-dashmap" ,rust-dashmap-5)
+ ("rust-extract-map" ,rust-extract-map-0.1)
+ ("rust-halfbrown" ,rust-halfbrown-0.2)
+ ("rust-hashbrown" ,rust-hashbrown-0.14)
+ ("rust-mini-moka" ,rust-mini-moka-0.10)
+ ("rust-nonmax" ,rust-nonmax-0.5)
+ ("rust-parking-lot" ,rust-parking-lot-0.12)
+ ("rust-secrecy" ,rust-secrecy-0.8)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-simd-json" ,rust-simd-json-0.13)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-typesize-derive" ,rust-typesize-derive-0.1)
+ ("rust-url" ,rust-url-2))))
+ (home-page "https://github.com/GnomedDev/typesize")
+ (synopsis
+ "Library to fetch an accurate estimate of the total memory usage of a value")
+ (description
+ "This package provides a library to fetch an accurate estimate of the total
+memory usage of a value.")
+ (license license:expat)))
+
(define-public rust-typesize-derive-0.1
(package
(name "rust-typesize-derive")