aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 06:40:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 21:41:51 +0100
commitb55cd95260988f365958ed5e4b1482be69197bb8 (patch)
tree4faef6a66d2414f65b54a7b904bf49ef52fe46d5 /gnu
parent8175ed6fd30cb916a81a3236d47fb71b69ece815 (diff)
downloadguix-b55cd95260988f365958ed5e4b1482be69197bb8.tar.gz
guix-b55cd95260988f365958ed5e4b1482be69197bb8.zip
gnu: gphoto2: Update to 2.5.28.
* gnu/packages/photo.scm (gphoto2): Update to 2.5.28. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/photo.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 785f795e99..913e1070f7 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -267,14 +267,14 @@ from digital cameras.")
(define-public gphoto2
(package
(name "gphoto2")
- (version "2.5.27")
+ (version "2.5.28")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gphoto/gphoto/" version
"/gphoto2-" version ".tar.bz2"))
(sha256
(base32
- "0f4d3q381jnnkcqkb2dj1k709skp65qihl5xm80zandvl69lw19h"))))
+ "0xbki37q9ja34igidr2vj0ps1lp7sfz4xpsmh8h9x89dy76qsr1a"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
@@ -287,13 +287,10 @@ from digital cameras.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* (find-files "tests/data" "\\.param$")
(("/usr/bin/env")
- (which "env")))
- #t)))
-
+ (which "env"))))))
;; FIXME: There is 1 test failure, most likely related to the build
;; environment.
#:tests? #f))
-
(home-page "http://www.gphoto.org/")
(synopsis "Command-line tools to access digital cameras")
(description
ake-ext-image): and pass file-system options to mke2fs. Mathieu Othacehe 2020-05-26build: image: Add support for EXT2 and EXT3 file-systems....* gnu/build/image.scm (make-ext4-image): Rename to ... (make-ext-image): ... it, and pass the file-system type to mke2fs, (make-partition-image): Adapt to call "make-ext-image" if the partition file-system is prefixed by "ext". Mathieu Othacehe 2020-05-05image: Add a new API....Raw disk-images and ISO9660 images are created in a Qemu virtual machine. This is quite fragile, very slow, and almost unusable without KVM. For all these reasons, add support for host image generation. This implies the use new image generation mechanisms. - Raw disk images: images of partitions are created using tools such as mke2fs and mkdosfs depending on the partition file-system type. The partition images are then assembled into a final image using genimage. - ISO9660 images: the ISO root directory is populated within the store. GNU xorriso is then called on that directory, in the exact same way as this is done in (gnu build vm) module. Those mechanisms are built upon the new (gnu image) module. * gnu/image.scm: New file. * gnu/system/image.scm: New file. * gnu/build/image: New file. * gnu/local.mk: Add them. * gnu/system/vm.scm (system-disk-image): Rename to system-disk-image-in-vm. * gnu/ci.scm (qemu-jobs): Adapt to new API. * gnu/tests/install.scm (run-install): Ditto. * guix/scripts/system.scm (system-derivation-for-action): Ditto. Mathieu Othacehe