aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-10-12 12:46:24 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-10-12 15:06:19 +0200
commitb418fdb191808783fd60e9b858567fd642e32634 (patch)
tree062ddcbe7c01132c6f8162eb2f191ef2569c58fd /gnu
parent1328c4cca531318e3ed90c6aecb522a5b22a4bcc (diff)
downloadguix-b418fdb191808783fd60e9b858567fd642e32634.tar.gz
guix-b418fdb191808783fd60e9b858567fd642e32634.zip
gnu: Add r-complexupset.
* gnu/packages/cran.scm (r-complexupset): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 459c6a6c93..1c37635ea5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10602,6 +10602,29 @@ the Singular Value Decomposition in R (Beaton et al 2014)
the matrix exponential and logarithm, and the determinant.")
(license license:gpl2)))
+(define-public r-complexupset
+ (package
+ (name "r-complexupset")
+ (version "1.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ComplexUpset" version))
+ (sha256
+ (base32 "1sk4v5kc2wkgfaws0hjlp30mngm907r5gz1iglf68j46lfs9jbsv"))))
+ (properties `((upstream-name . "ComplexUpset")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-colorspace r-ggplot2 r-patchwork r-scales))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/krassowski/complex-upset")
+ (synopsis "Create complex UpSet plots using ggplot2 components")
+ (description
+ "@code{UpSet} plots are an improvement over Venn Diagram for set overlap
+visualizations. Striving to bring the best of the @code{UpSetR} and ggplot2,
+this package offers a way to create complex overlap visualisations, using
+simple and familiar tools.")
+ (license license:expat)))
+
(define-public r-phontools
(package
(name "r-phontools")