aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-22 09:14:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:28:58 +0300
commitb29aaf42bb5d3decba3ac7631367d258581347cf (patch)
tree117a3f1f2a4c6d3dbe0f50f3c698a2fa2102c66e /gnu
parenta8ee3422e5e445e79949d2939da47a50be155980 (diff)
downloadguix-b29aaf42bb5d3decba3ac7631367d258581347cf.tar.gz
guix-b29aaf42bb5d3decba3ac7631367d258581347cf.zip
gnu: Add rust-aes-gcm-0.10.
* gnu/packages/crates-io.scm (rust-aes-gcm-0.10): New variable. (rust-aes-gcm-0.8): Inherit from rust-aes-gcm-0.10.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm43
1 files changed, 34 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 87880a060f..a31b9043c3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1966,29 +1966,30 @@ ciphers implementations.")
("rust-aesni" ,rust-aesni-0.6)
("rust-block-cipher-trait" ,rust-block-cipher-trait-0.6))))))
-(define-public rust-aes-gcm-0.8
+(define-public rust-aes-gcm-0.10
(package
(name "rust-aes-gcm")
- (version "0.8.0")
+ (version "0.10.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "aes-gcm" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1nl8iwlh209y1vj9n2lm1a70i69clvg2z6x69bi4dgdrpgxbay2j"))))
+ (base32 "0z2429v2d2wyf809h2wc4vwwibwypz3y4p7sn4kzkjb91ip3dqc2"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-aead" ,rust-aead-0.3)
- ("rust-aes" ,rust-aes-0.6)
- ("rust-cipher" ,rust-cipher-0.2)
- ("rust-ctr" ,rust-ctr-0.6)
- ("rust-ghash" ,rust-ghash-0.3)
+ (("rust-aead" ,rust-aead-0.5)
+ ("rust-aes" ,rust-aes-0.8)
+ ("rust-cipher" ,rust-cipher-0.4)
+ ("rust-ctr" ,rust-ctr-0.9)
+ ("rust-ghash" ,rust-ghash-0.5)
("rust-subtle" ,rust-subtle-2)
("rust-zeroize" ,rust-zeroize-1))
#:cargo-development-inputs
- (("rust-hex-literal" ,rust-hex-literal-0.2))))
+ (("rust-aead" ,rust-aead-0.5)
+ ("rust-hex-literal" ,rust-hex-literal-0.3))))
(home-page "https://github.com/RustCrypto/AEADs")
(synopsis "AES-GCM (Galois/Counter Mode) Authenticated Encryption")
(description "This package provides a pure Rust implementation of the
@@ -1997,6 +1998,30 @@ Data (AEAD) Cipher with optional architecture-specific hardware
acceleration.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-aes-gcm-0.8
+ (package
+ (inherit rust-aes-gcm-0.10)
+ (name "rust-aes-gcm")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "aes-gcm" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1nl8iwlh209y1vj9n2lm1a70i69clvg2z6x69bi4dgdrpgxbay2j"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aead" ,rust-aead-0.3)
+ ("rust-aes" ,rust-aes-0.6)
+ ("rust-cipher" ,rust-cipher-0.2)
+ ("rust-ctr" ,rust-ctr-0.6)
+ ("rust-ghash" ,rust-ghash-0.3)
+ ("rust-subtle" ,rust-subtle-2)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-hex-literal" ,rust-hex-literal-0.2))))))
+
(define-public rust-aes-gcm-0.6
(package
(inherit rust-aes-gcm-0.8)