aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-10 15:38:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:50:26 +0100
commitaed6d241483d2843c4d5053dda919688f7882f25 (patch)
tree3a916fd28135f51c985a5351981b7443aec3fff2 /gnu
parentb9bf6c222b6a255d9c07c0600808806b43ac3011 (diff)
downloadguix-aed6d241483d2843c4d5053dda919688f7882f25.tar.gz
guix-aed6d241483d2843c4d5053dda919688f7882f25.zip
gnu: Add rust-shellexpand-2.
* gnu/packages/crates-io.scm (rust-shellexpand-2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4303bbd7b1..93e6ee0161 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35734,6 +35734,32 @@ shell.")
(sha256
(base32 "0jnrw3f174974fsi2hg48l0klpy24767ib28w0xcvi2ll5axxb1r"))))))
+(define-public rust-shellexpand-2
+ (package
+ (name "rust-shellexpand")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "shellexpand" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0a981ynym0hipnvkd93ihszdszjqs0cslj5ilzsdv19d3f1vggc3"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-dirs-next" ,rust-dirs-next-2))))
+ (home-page "https://github.com/netvl/shellexpand")
+ (synopsis "Shell-like expansions in strings")
+ (description
+ "@code{shellexpand} is a single dependency library which allows one to
+perform shell-like expansions in strings, that is, to expand variables like
+@samp{$A} or @samp{$@{B@}} into their values inside some context and to expand
+@samp{~} in the beginning of a string into the home directory (again, inside
+some context).")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-shlex-0.1
(package
(name "rust-shlex")