aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-21 17:35:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:26 +0100
commitae63ff8dca9ca2a2c2f900099affa65b41584273 (patch)
treeb35c97b8f7f95bae33adeab195e9bc22a0a05f55 /gnu
parent43b061aaf6fbf4c03d61abb2e0a2611c41ba5f5e (diff)
downloadguix-ae63ff8dca9ca2a2c2f900099affa65b41584273.tar.gz
guix-ae63ff8dca9ca2a2c2f900099affa65b41584273.zip
gnu: pyscenic: Update to 0.12.1-1.eaf23eb.
* gnu/packages/bioinformatics.scm (pyscenic): Update to 0.12.1-1.eaf23eb. [arguments]: Update phase 'do-not-reference-deleted-modules. [propagated-inputs]: Add python-numexpr. [native-inputs]: Add python-wheel. Change-Id: Ib1b5a7d36a24b280160befe579057a241d69455d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm58
1 files changed, 31 insertions, 27 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 449e6dd5f2..433e60a47c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -21123,12 +21123,14 @@ tree-based ensemble regressors.")
(license license:bsd-3)))
(define-public pyscenic
- ;; Latest commit from the update-pyarrow branch
- (let ((commit "5f170fdf474548c37ab381d1849c662820d658ee")
+ ;; We use this commit because the last release is not compatible with the
+ ;; current version of numpy. See
+ ;; https://github.com/aertslab/pySCENIC/issues/579#issuecomment-2405207860
+ (let ((commit "eaf23eb1fdcaae79b273de56b374b71aa8afde5a")
(revision "1"))
(package
(name "pyscenic")
- (version (git-version "0.11.2" revision commit))
+ (version (git-version "0.12.1" revision commit))
(source
(origin
(method git-fetch)
@@ -21138,7 +21140,7 @@ tree-based ensemble regressors.")
(file-name (git-file-name name version))
(sha256
(base32
- "03qkvy400rjndg2ds6bhcaprir71mqr2v3yv9vd77lcnzxgw3s0z"))))
+ "1si2ifmj0cy2yba8lw5m7mg97iqaxi0cwhy3j43rz5bzkp0cah8n"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -21149,43 +21151,45 @@ tree-based ensemble regressors.")
(add-after 'unpack 'do-not-reference-deleted-modules
(lambda _
(substitute* "setup.py"
- (("'db2feather = .*',") "")
- (("'invertdb = .*',") "")
- (("'gmt2regions = pyscenic.cli.gmt2regions:main'") ""))))
+ (("\"db2feather = .*\",") "")
+ (("\"csv2loom = .*\",") "")
+ (("\"invertdb = .*\",") "")
+ (("\"gmt2regions = .*\",") ""))))
;; Numba needs a writable dir to cache functions.
(add-before 'check 'set-numba-cache-dir
(lambda _
(setenv "NUMBA_CACHE_DIR" "/tmp"))))))
(propagated-inputs
- (list python-ctxcore
- python-cytoolz
- python-multiprocessing-on-dill
- python-llvmlite
- python-numba
+ (list python-aiohttp
+ python-arboreto
python-attrs
- python-frozendict
- python-numpy
- python-pandas
+ python-boltons
python-cloudpickle
+ python-ctxcore
+ python-cytoolz
python-dask
- python-pyarrow ;XXX for dask
python-distributed
- python-arboreto
- python-boltons
- python-setuptools
- python-pyyaml
- python-tqdm
+ python-frozendict
+ python-fsspec
python-interlap
- python-umap-learn
+ python-llvmlite
python-loompy
+ python-multiprocessing-on-dill
python-networkx
- python-scipy
- python-fsspec
+ python-numba
+ python-numexpr
+ python-numpy
+ python-pandas
+ python-pyarrow ;XXX for dask
+ python-pyyaml
python-requests
- python-aiohttp
- python-scikit-learn))
+ python-scikit-learn
+ python-scipy
+ python-setuptools
+ python-tqdm
+ python-umap-learn))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-wheel))
(home-page "https://scenic.aertslab.org/")
(synopsis "Single-Cell regulatory network inference and clustering")
(description