aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:28:11 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:28:11 +0100
commitade6845da6cec99f3bca46faac9b2bad6877817e (patch)
treeaa6ea911d9ee601981c5d67153ba7aa286160af5 /gnu
parent6ca7d1a6159b3153cf64806dfe06f39516ae160a (diff)
downloadguix-ade6845da6cec99f3bca46faac9b2bad6877817e.tar.gz
guix-ade6845da6cec99f3bca46faac9b2bad6877817e.zip
gnu: go-github-com-hashicorp-hcl-v2: Sort alphabetically.
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-hcl-v2): Sort alphabetically. Change-Id: I8a22e7d56721168bb427f056037583d150d9edd5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm64
1 files changed, 32 insertions, 32 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 461d67f8bc..d357584469 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1083,38 +1083,6 @@ while callers can implement logging with whatever backend is appropriate.")
wrapping errors and checking if an error contains another error.")
(license license:mpl2.0)))
-(define-public go-github-com-hashicorp-hcl-v2
- (package
- (name "go-github-com-hashicorp-hcl-v2")
- (version "2.11.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hashicorp/hcl")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0f9flmmkj7fr1337fc56cqy73faq87ix375hnz3id4wc023przv1"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/hashicorp/hcl/v2"))
- (native-inputs
- (list go-github-com-davecgh-go-spew))
- (inputs
- (list go-github-com-agext-levenshtein
- go-github-com-apparentlymart-go-textseg-v13
- go-github-com-mitchellh-go-wordwrap
- go-github-com-zclconf-go-cty))
- (synopsis "Go implementation of HashiCorp Configuration Language V2")
- (description
- "This package contains the main implementation of the @acronym{HCL,
-HashiCorp Configuration Language}. HCL is designed to be a language for
-expressing configuration which is easy for both humans and machines to read.")
- (home-page "https://github.com/hashicorp/hcl")
- (license license:mpl2.0)))
-
(define-public go-github-com-hashicorp-go-hclog
(package
(name "go-github-com-hashicorp-go-hclog")
@@ -1280,6 +1248,38 @@ expressing configuration which is easy for both humans and machines to read.")
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-hcl-v2
+ (package
+ (name "go-github-com-hashicorp-hcl-v2")
+ (version "2.11.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/hcl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f9flmmkj7fr1337fc56cqy73faq87ix375hnz3id4wc023przv1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/hcl/v2"))
+ (native-inputs
+ (list go-github-com-davecgh-go-spew))
+ (inputs
+ (list go-github-com-agext-levenshtein
+ go-github-com-apparentlymart-go-textseg-v13
+ go-github-com-mitchellh-go-wordwrap
+ go-github-com-zclconf-go-cty))
+ (synopsis "Go implementation of HashiCorp Configuration Language V2")
+ (description
+ "This package contains the main implementation of the @acronym{HCL,
+HashiCorp Configuration Language}. HCL is designed to be a language for
+expressing configuration which is easy for both humans and machines to read.")
+ (home-page "https://github.com/hashicorp/hcl")
+ (license license:mpl2.0)))
+
(define-public go-github-com-hhrutter-tiff
(package
(name "go-github-com-hhrutter-tiff")